Project

General

Profile

Bug #29435

Tracer shows the machines needs rebooting even after reboot if kernel-debug is installed

Added by Jonathon Turel 7 months ago. Updated 7 months ago.

Status:
Closed
Priority:
Normal
Category:
Tooling
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1709842

Description of problem:

- If the kernel-debug is installed on the machine, the tracer command output will be like the following even after rebooting the machine.

You should restart: * These applications rebooting your computer:
kernel
- This will case the machine to be marked as "Reboot Required" on the machine Properties and on Content Hosts

Application | Type | Helper
kernel | static | You will have to reboot your computer

Version-Release number of selected component (if applicable):

katello-host-tools-tracer-3.3.5-3.el7sat.noarch
tracer-common-0.7.0-3.el7sat.noarch
python2-tracer-0.7.0-3.el7sat.noarch

*How reproducible:*Confirmed

Steps to Reproduce:
1. Install katello-host-tools-tracer package on any registered machine.
2. Install kernel-debug package
3. Reboot the machine.
4. Run "tracer -a"
5. Check the machine on the satellite "All Hosts" and "Content Hosts -> Traces"

Actual results:

You should restart: * These applications rebooting your computer:
kernel

Expected results:

The machine does not need to be rebooted because of the kernel.

History

#1 Updated by Jonathon Turel 7 months ago

  • Target version set to Katello 3.16.0
  • Category set to Tooling
  • Subject changed from Tracer shows the machines needs rebooting even after reboot if kernel-debug is installed to Tracer shows the machines needs rebooting even after reboot if kernel-debug is installed
  • Pull request https://github.com/FrostyX/tracer/pull/134 added

#2 Updated by Jonathon Turel 7 months ago

  • Status changed from New to Ready For Testing

#3 Updated by Jonathon Turel 7 months ago

  • Status changed from Ready For Testing to Closed

#4 Updated by James Jeffers 7 months ago

  • Triaged changed from No to Yes

Also available in: Atom PDF