Project

General

Profile

Bug #29458

Syncing of repos got stuck in foreman (katello nightly version )

Added by Imaan please_edit_me about 2 years ago. Updated about 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Katello Version:
nightly (https://theforeman.org/plugins/katello/nightly/installation/index.html)

[root@katello ~]# rpm -qa | grep katello
katello-selinux-3.1.1-1.el7.noarch
katello-common-3.16.0-0.2.master.el7.noarch
katello.contperfkn.local-qpid-broker-1.0-1.noarch
foreman-installer-katello-2.1.0-0.1.develop.20200402042220gita3a0fe6.el7.noarch
katello-3.16.0-0.2.master.el7.noarch
katello-server-ca-1.0-1.noarch
katello.contperfkn.local-qpid-router-server-1.0-1.noarch
katello-repos-3.15.0-0.3.nightly.el7.noarch
katello-client-bootstrap-1.7.4-1.el7.noarch
katello.contperfkn.local-foreman-client-1.0-1.noarch
katello.contperfkn.local-qpid-client-cert-1.0-1.noarch
katello.contperfkn.local-qpid-router-client-1.0-1.noarch
tfm-rubygem-hammer_cli_katello-0.22-0.3.pre.master.20200313010517git603cd84.el7.noarch
tfm-rubygem-katello-3.16.0-0.6.pre.master.20200401201105gitd6fcd61.el7.noarch
pulp-katello-1.0.3-1.el7.noarch
katello.contperfkn.local-foreman-proxy-1.0-1.noarch
katello.contperfkn.local-puppet-client-1.0-1.noarch
katello-certs-tools-2.6.0-2.el7.noarch
katello-default-ca-1.0-1.noarch
katello.contperfkn.local-foreman-proxy-client-1.0-1.noarch
katello-debug-3.16.0-0.2.master.el7.noarch
katello.contperfkn.local-apache-1.0-1.noarch

[root@katello ~]# rpm -qa | grep foreman
foreman-cli-2.1.0-0.6.develop.20200401184454git4ac4045.el7.noarch
tfm-rubygem-hammer_cli_foreman_tasks-0.0.14-1.fm2_1.el7.noarch
foreman-installer-katello-2.1.0-0.1.develop.20200402042220gita3a0fe6.el7.noarch
foreman-release-2.1.0-0.1.develop.el7.noarch
foreman-installer-2.1.0-0.1.develop.20200402042220gita3a0fe6.el7.noarch
foreman-postgresql-2.1.0-0.6.develop.20200401184454git4ac4045.el7.noarch
foreman-release-scl-7-2.el7.noarch
tfm-rubygem-foreman-tasks-core-0.3.4-1.fm2_1.el7.noarch
tfm-rubygem-hammer_cli_foreman_bootdisk-0.3.0-1.el7.noarch
foreman-2.1.0-0.6.develop.20200401184454git4ac4045.el7.noarch
foreman-dynflow-sidekiq-2.1.0-0.6.develop.20200401184454git4ac4045.el7.noarch
katello.contperfkn.local-foreman-client-1.0-1.noarch
tfm-rubygem-hammer_cli_foreman-2.1.0-0.1.pre.develop.20200330153552git5a74fee.el7.noarch
foreman-proxy-2.1.0-0.1.develop.20200323170352gitbe5fb74.el7.noarch
katello.contperfkn.local-foreman-proxy-1.0-1.noarch
foreman-debug-2.1.0-0.6.develop.20200401184454git4ac4045.el7.noarch
katello.contperfkn.local-foreman-proxy-client-1.0-1.noarch
rubygem-foreman_maintain-0.6.2-1.el7.noarch
tfm-rubygem-foreman-tasks-1.0.1-3.fm2_0.el7.noarch
foreman-selinux-2.1.0-0.1.develop.20200213185945git6755e39.el7.noarch
tfm-rubygem-hammer_cli_foreman_docker-0.0.4-4.el7.noarch
[root@katello ~]#

Issue Description :
- Tried to sync 20 repos using this script (https://github.com/redhat-performance/satperf/blob/master/experiment/sync.sh)
- out of 20 only 4 got synced
- rest is still in the running state and the result is pending.

I have checked the task id of one of the pending sync repo, it shows 43% completed and in dynflow console showing stuck at the following action

"Actions::Pulp::Repository::Sync (waiting for Pulp to finish the task) [ 400.38s / 2.34s ]"

Please take a look at the attached images which describe the error and more details related to it.

dynflow.png View dynflow.png 62.5 KB Imaan please_edit_me, 04/02/2020 11:58 AM
sync-task.png View sync-task.png 57.9 KB Imaan please_edit_me, 04/02/2020 12:56 PM
foreman-debug-Ld8mz.tar.xz foreman-debug-Ld8mz.tar.xz 929 KB Imaan please_edit_me, 04/02/2020 02:09 PM
Dynflow Sync task

Related issues

Is duplicate of Katello - Bug #29370: Syncing a large product leaves Pulp tasks "waiting".New

History

#1 Updated by Imaan please_edit_me about 2 years ago

I am attaching foreman debug report for reference.

#2 Updated by Justin Sherrill about 2 years ago

  • Is duplicate of Bug #29370: Syncing a large product leaves Pulp tasks "waiting". added

#3 Updated by Justin Sherrill about 2 years ago

  • Status changed from New to Duplicate

#4 Updated by Ian Ballou about 2 years ago

  • Triaged changed from No to Yes
  • Target version set to Katello Recycle Bin

Also available in: Atom PDF