Project

General

Profile

Bug #29493

Can't search Hosts/Hostgroup by Parameter

Added by Lars Wagner over 1 year ago. Updated 9 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Host groups
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

If I try to search a host or hostgroup by a paramter like:

has params.myparameter

This gives me in the hosts section the following error:

undefined method `table_name' for nil:NilClass

and in the host group search the following error:

Invalid search query: Field 'params.myparam' not recognized for searching!

We are running foreman version 1.24.2.

If you need any further information, just let me know.


Related issues

Related to Foreman - Bug #29683: Unable to search by value of certain Hostgroup parameterClosed

History

#1 Updated by Lars Wagner over 1 year ago

  • Related to Bug #29683: Unable to search by value of certain Hostgroup parameter added

#2 Updated by Lars Wagner 9 months ago

The error is still the same on the latest foreman release 2.3.3. Might somebody be able to have a look into it? The problem is the same for the host and hostgroup search:

undefined method `table_name' for nil:NilClass

#3 Updated by Lars Wagner 9 months ago

  • Category set to Host groups

#4 Updated by Lars Wagner 9 months ago

  • Status changed from New to Resolved

Parameters can be search liked that:

params.myparam != ""

Also available in: Atom PDF