Project

General

Profile

Bug #2956

Autocompletion failure when adding class to host

Added by Raphaƫl PINSON almost 7 years ago. Updated almost 3 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Search
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

I've got a class called `local_tmpl::app::c2c_sig_demo`.

When I want to assign it to a host, I edit the host, go to the "Puppet Classes" tab and type the name.

When I type "c2c_sig", it shows up (along with a lot of other classes).

If I keep typing and add "c2c_sig_d", only "local_tmpl::app::c2c_sig_dev" shows up, even though it should also match "local_tmpl::app::c2c_sig_demo".

This makes it hard to add classes to hosts, since the Puppet Classes section in Configuration allows to add classes to hostgroups, not hosts.


Related issues

Is duplicate of Foreman - Bug #14636: Unable to search puppet classes with long namesClosed2016-04-14

History

#1 Updated by Dominic Cleal almost 7 years ago

  • Category set to Search

#2 Updated by Tomer Brisker almost 3 years ago

  • Is duplicate of Bug #14636: Unable to search puppet classes with long names added

#3 Updated by Tomer Brisker almost 3 years ago

  • Status changed from New to Duplicate

I believe this was solved in 14636, closing as duplicate. please reopen if issue persists.

Also available in: Atom PDF