Project

General

Profile

Feature #29572

Ansible Role execution reports are not exactly human readable

Added by Shira Maximov over 1 year ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1810600

Description of problem: When Ansible Roles are executed Ansible report is create, but it is marked in reports with origin N/A instead of Ansible

Version-Release number of selected component (if applicable):
tfm-rubygem-foreman_ansible-3.0.7.1-1.el7sat.noarch
ansible-2.8.8-1.el7ae.noarch

How reproducible: Always

Steps to Reproduce:
1. Create host with attached ansible roles
2. WebUI -> All Hosts -> Select Host -> Select Action -> Play Ansible roles
3. Wait until finished
4. WebUI -> Monitor -> Config Management
5. remove filter
6. select Ansible report

Actual results:
in step 6. you see json output

for example:

{"foreman": {"owner_name": "Admin User", "foreman_host_collections": [], "content_view_info": {"published": "2020-03-05T13:33:55.111Z", "version": "2.0", "latest-version": "2.0", "components": {}, "label": "RHEL8"}, "ssh_authorized_keys": [], "domainname": "x.example.com", "owner_email": "", "root_pw": "example", "location_title": "LOCATION", "foreman_users": {"admin": {"name": "admin", "ssh_authorized_keys": [], "mail": "", "firstname": "Admin", "lastname": "User", "fullname": "Admin User", "description": null}}, "lifecycle_environment": "LE", "kt_cv": "CV", "foreman_env": "common", "puppet_ca": "ca.x.example.com", "foreman_subnets": [{"dns_primary": "127.0.0.1", "network_type": "IPv4", "from": "192.168.1.2", "description": "", "name": "192.168.1.254", "ipam": "DHCP", "mask": "255.255.255.0", "vlanid": null, "mtu": 1500, "to": "192.168.1.10", "dns_secondary": "", "gateway": "192.168.1.1", "network": "192.168.1.10", "boot_mode": "DHCP"}], "foreman_config_groups": [], "foreman_domain_description": "", "content_view": "CV", "hostgroup": "CV/CV-prod", "kickstart_repository": "Red_Hat_Enterprise_Linux_8_for_x86_64_-_BaseOS_Kickstart_x86_64_8_1", "organization_title": "ORG", "puppetmaster": "sat.x.example.com", "kt_env": "common", "location": "LOC", "foreman_interfaces": [{"managed": true, "ip": "192.168.1.10", "primary": true, "mac": "AA:BB:CC:DD:EE:FF", "tag": null, "ip6": null, "attrs": {"netmask6": "ffff:ffff:ffff:ffff::", "network": "192.168.1.10", "bindings6": [{"netmask": "ffff:ffff:ffff:ffff::", "network": "fe80::", "address": "fe80::5054:ff:fe9b:ef84"}], "mtu": 1500, "netmask": "255.255.255.0", "network6": "fe80::", "dhcp": "192.168.1.10", "bindings": [{"netmask": "255.255.255.0", "network": "192.168.1.10", "address": "192.168.1.10"}]}, "subnet6": null, "provision": true, "subnet": {"dns_primary": "127.0.0.1", "network_type": "IPv4", "from": "192.168.1.2", "description": "", "name": "192.168.1.10", "ipam": "DHCP", "mask": "255.255.255.0", "vlanid": null, "mtu": 1500, "to": "192.168.1.254", "dns_secondary": "", "gateway": "192.168.1.1", "network": "192.168.1.10", "boot_mode": "DHCP"}, "attached_to": null, "name": "host.x.example.com", "virtual": false, "link": true, "identifier": "ens3", "type": "Interface"}], "organization": "ORG"}, "changed": false, "_ansible_verbose_always": true, "_ansible_no_log": false}

Expected results:
Human readable output


Related issues

Is duplicate of Ansible - Feature #32189: Improve ansible config report dataClosed

History

#1 Updated by Tomer Brisker over 1 year ago

  • Subject changed from Ansible Role execution reports are not exactly human readable to Ansible Role execution reports are not exactly human readable
  • Project changed from Foreman to Ansible

#2 Updated by Alexandre Barth over 1 year ago

An output like in this video https://www.youtube.com/watch?v=gY-lbZ8XoLA at 12:00 would be great.

#3 Updated by yifat makias 5 months ago

  • Is duplicate of Feature #32189: Improve ansible config report data added

#4 Updated by yifat makias 5 months ago

  • Status changed from New to Closed

Also available in: Atom PDF