Project

General

Profile

Bug #29592

Repository Upstream Authentication can never be removed

Added by Markus Bucher over 1 year ago. Updated 9 months ago.

Status:
Closed
Priority:
Normal
Category:
Repositories
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

On Repository Details page The 'X' icon for the Upstream Authentication does not work.

You can click it and it does save the Repository, but after reload the Authentication credentials reappear.

Among others, the GUI sends the following parameters to the API and I think the second one being true might be the problem:

upstream_auth_exists: false
upstream_password_exists: true

Associated revisions

Revision e7a0436a (diff)
Added by Justin Sherrill 9 months ago

Fixes #29592 - properly clear upstream auth

on repo details page

History

#1 Updated by Jonathon Turel over 1 year ago

  • Triaged changed from No to Yes
  • Target version set to 1223

#2 Updated by Jonathon Turel over 1 year ago

  • Target version changed from 1223 to Katello 4.0.0

#3 Updated by Chris Roberts about 1 year ago

  • Target version changed from Katello 4.0.0 to Katello 3.17.0

#4 Updated by Chris Roberts about 1 year ago

  • Target version changed from Katello 3.17.0 to Katello 3.18.0

#5 Updated by Jonathon Turel 10 months ago

  • Target version changed from Katello 3.18.0 to Katello 4.0.0
  • Found in Releases deleted (Katello 3.14.1, Katello Backlog)

#6 Updated by The Foreman Bot 9 months ago

  • Assignee set to Justin Sherrill
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/9124 added

#7 Updated by The Foreman Bot 9 months ago

  • Fixed in Releases Katello 4.1.0 added

#8 Updated by Justin Sherrill 9 months ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF