Project

General

Profile

Bug #29605

babel-plugin-dynamic-import-node 2.3.3 breaks webpack compile

Added by Tomer Brisker 5 months ago. Updated 5 months ago.

Status:
Ready For Testing
Priority:
Normal
Assignee:
Category:
JavaScript stack
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:

Description

The dynamic imports in i18n.js no longer work with this version, causing compile failures.

Associated revisions

Revision 10e7aa5c (diff)
Added by Tomer Brisker 5 months ago

Refs #29605 - pin babel-plugin-dynamic-import-node

Release 2.3.3 of this plugin causes webpack compile to fail on dynamic
imports in I18n.js. Pinning to known good version.

Revision e55afbce (diff)
Added by Ondřej Ezr 5 months ago

Refs #29605 - pin more more of babel-plugin-dyncamic-import-node

Release babel-plugin-dyncamic-import-node 2.3.3 brought breaking change
@babel/preset-env is bringing new plugins `systemjs`, `commonjs`, `amd` versions 7.9.6
those all depend on babel-plugin-dyncamic-import-node ^2.3.3

History

#1 Updated by The Foreman Bot 5 months ago

  • Assignee set to Tomer Brisker
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/7604 added

#2 Updated by The Foreman Bot 5 months ago

  • Pull request https://github.com/theforeman/foreman/pull/7622 added

Also available in: Atom PDF