Project

General

Profile

Feature #29616

Fix Capsule upgrade playbook template

Added by Vladimir Sedmik 10 months ago. Updated 6 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

We should omit the --whitelist option from the 'foreman-maintain upgrade' command when no whitelist option is provided. Otherwise the foreman-maintain would complain with "ERROR: option '--whitelist': value not specified".

https://github.com/theforeman/community-templates/pull/716/files#diff-1b0569864108e5f4eb4844072c96188bR44


Related issues

Related to Foreman Remote Execution - Tracker #29643: Capsule upgrade playbook trackerClosed

Is duplicate of Ansible - Bug #30545: UI dialog for Capsule Upgrade Playbook job doesn't state whitelist_options is requiredClosed

History

#1 Updated by Suresh Thirugnanasambandan 10 months ago

#2 Updated by Vladimir Sedmik 8 months ago

Please also fix names for ‘target_version’ and ‘whitelist_options’ inputs.

#3 Updated by Adam Ruzicka 8 months ago

  • Project changed from Foreman Remote Execution to Ansible

All the requested changes will need to be done in community-templates and ansible, changing the project.

#4 Updated by Tomer Brisker 6 months ago

  • Status changed from New to Duplicate

this was resolved in #30545

#5 Updated by Tomer Brisker 6 months ago

  • Is duplicate of Bug #30545: UI dialog for Capsule Upgrade Playbook job doesn't state whitelist_options is required added

Also available in: Atom PDF