Project

General

Profile

Bug #29619

transient test failure content_view_component_test.rb:125:in `test_latest_versions' (ActiveRecord::RecordInvalid)

Added by Justin Sherrill about 2 years ago. Updated about 2 years ago.

Status:
Duplicate
Priority:
Normal
Category:
Tests
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

ActiveRecord::RecordInvalid: Validation failed: Minor , must be unique to major and version id version....
Stacktrace
ActiveRecord::RecordInvalid: Validation failed: Minor , must be unique to major and version id version.
test/factories/disable_auditing.rb:13:in `block (3 levels) in <top (required)>'
test/factories/disable_auditing.rb:13:in `block (2 levels) in <top (required)>'
/home/jenkins/workspace/katello-pr-test/test/models/content_view_component_test.rb:125:in `test_latest_versions' (ActiveRecord::RecordInvalid)
/usr/local/rvm/gems/ruby-2.5.1@jenkins-katello-pr-test-3593-2/gems/activerecord-5.2.1/lib/active_record/validations.rb:52


Related issues

Is duplicate of Katello - Bug #29657: Intermittent ContentViewComponent testClosed

History

#1 Updated by The Foreman Bot about 2 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/8679 added

#2 Updated by Justin Sherrill about 2 years ago

  • Triaged changed from No to Yes
  • Target version set to Katello Recycle Bin
  • Status changed from Ready For Testing to Duplicate

#3 Updated by Justin Sherrill about 2 years ago

  • Is duplicate of Bug #29657: Intermittent ContentViewComponent test added

Also available in: Atom PDF