Project

General

Profile

Bug #2964

Hammer fails on search by name containig spaces

Added by Martin Bacovsky almost 7 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:
In Kanboard:

Description

The issue is probably deeper (ForemanAPI or API itself)

Associated revisions

Revision 01c94592 (diff)
Added by Tomas Strachota almost 7 years ago

fixes #2964 - url parameters not being encoded

Revision 1e1ad055
Added by Tomas Strachota almost 7 years ago

Merge pull request #18 from tstrachota/escaping

fixes #2964 - url parameters not being encoded

History

#1 Updated by Sam Kottler almost 7 years ago

Is this true even if names are properly escaped?

#3 Updated by Tomáš Strachota almost 7 years ago

  • Status changed from New to Assigned
  • Assignee set to Tomáš Strachota

The API itself seems to be ok. It's just the bindings not escaping parameters.

#4 Updated by Tomáš Strachota almost 7 years ago

  • Status changed from Assigned to Ready For Testing

#5 Updated by Tomáš Strachota almost 7 years ago

  • Status changed from Ready For Testing to Closed

#6 Updated by Dominic Cleal over 6 years ago

  • Project changed from Foreman to Hammer CLI
  • Category deleted (44)

Also available in: Atom PDF