Project

General

Profile

Bug #29678

simultaneously syncing multiple LCEs on smart proxy fails due to "required lock" error

Added by William Clark over 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Urgent
Category:
Foreman Proxy Content
Target version:
Difficulty:
easy
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

when syncing multiple LCEs simultaneously to a smart proxy, sync tasks after the first will fail due to "required lock" error

to reproduce the issue:

1. publish a new version of a CV, promote it to multiple LCEs
2. if the smart proxy is configured to auto-sync when LCEs are updated, any sync tasks after the first one created will fail due to "required lock"

the proposed solution (thanks jsherrill!) is that the resource locks in `app/lib/actions/katello/capsule_content/sync_capsule.rb` need to be defined as only a 'linking' lock

Associated revisions

Revision 246d899a (diff)
Added by Justin Sherrill over 1 year ago

Fixes #29678 - do not lock smart proxy sync

History

#1 Updated by The Foreman Bot over 1 year ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/8695 added

#2 Updated by The Foreman Bot over 1 year ago

  • Fixed in Releases added

#3 Updated by Justin Sherrill over 1 year ago

  • Status changed from Ready For Testing to Closed

#4 Updated by Samir Jha over 1 year ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.15.1

#5 Updated by Justin Sherrill over 1 year ago

  • Bugzilla link set to 1830403

#6 Updated by Jonathon Turel about 1 year ago

  • Fixed in Releases Katello 3.17.0 added
  • Fixed in Releases deleted ()
  • Pull request deleted (https://github.com/Katello/katello/pull/8695)

Also available in: Atom PDF