Project

General

Profile

Refactor #29916

Remove chromedriver optional dependency

Added by Ewoud Kohl van Wijngaarden 3 months ago. Updated 3 months ago.

Status:
Duplicate
Priority:
Normal
Category:
Tests
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

This dependency is specified in package.json but is not actually used in the Javascript testing. It's used in Foreman's integration helper. However, our CI system already installs it via system packages which ensures it's in sync with the installed Chromium version. This avoids the need to regularly bump it (like #28028 among others).


Related issues

Is duplicate of Foreman - Bug #28028: chromedriver version mismatch with jenkins chromium versionClosed

History

#1 Updated by The Foreman Bot 3 months ago

  • Assignee set to Ewoud Kohl van Wijngaarden
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/7695 added

#2 Updated by Ewoud Kohl van Wijngaarden 3 months ago

  • Is duplicate of Bug #28028: chromedriver version mismatch with jenkins chromium version added

#3 Updated by Ewoud Kohl van Wijngaarden 3 months ago

  • Status changed from Ready For Testing to Duplicate

Also available in: Atom PDF