Project

General

Profile

Bug #29967

Root password in the provisioning settings should be encrypted instead of plain text.

Added by Suraj Patil 6 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Settings
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1807789

Description of problem:
If you navigate to Administer -> Settings and view the Root password option on the Provisioning tab, the value is not masked which ideally it should be.

Version-Release number of selected component (if applicable):
Red Hat Satellite 6.7 public beta.

How reproducible:
If you navigate to Administer -> Settings and view the Root password option on the Provisioning tab, the value is not encrypted, it should not be in the plain text.

Actual results:
The root password is visible to any user.

Expected results:
The root password should be in encrypted format.

Additional info:
NA.

Associated revisions

Revision c2832e77 (diff)
Added by Suraj Patil 6 months ago

Fixes #29967 - encrypte root password in settings

History

#1 Updated by Suraj Patil 6 months ago

  • Assignee set to Suraj Patil

#2 Updated by The Foreman Bot 6 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/7723 added

#3 Updated by The Foreman Bot 6 months ago

  • Fixed in Releases 2.2.0 added

#4 Updated by Suraj Patil 6 months ago

  • Status changed from Ready For Testing to Closed

#5 Updated by The Foreman Bot 3 months ago

  • Pull request https://github.com/theforeman/foreman/pull/7975 added

Also available in: Atom PDF