Project

General

Profile

Bug #29984

Array handled improperly, leading to ISE

Added by Shira Maximov 8 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Compute resources - oVirt
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1813986

Description of problem:
Request with size_gb=<some_array> leads to ISE. Passing an array for this parameter is incorrect but ISE is not a correct response.

Version-Release number of selected component (if applicable):
Reproduced with Sat 6.7

How reproducible:
Deterministic

Steps to Reproduce:
1. # hammer host create --hostgroup testgrp --location-id 2 --organization-id 1 --name lhellebr-delme-convert10 --ip 192.168.122.86 --volume "size_gb=[20],wipe_after_delete=[bla],storage_domain=<UUID>"
Could not create the host:
Internal Server Error: the server was unable to finish the request. This may be caused by unavailability of some required service, incorrect API call or a server-side bug. There may be more information in the server's logs.

Actual results:
ISE

Expected results:
Meaningful error message, like "Incorrect value of argument 'size_gb'"

Additional info:
Traceback not useful but attached

Associated revisions

Revision 21324ca8 (diff)
Added by Shira Maximov 5 months ago

Fixes #29984 - Validate all ovirt volume attrs are string

History

#1 Updated by The Foreman Bot 6 months ago

  • Assignee set to Shira Maximov
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/7873 added

#2 Updated by The Foreman Bot 5 months ago

  • Fixed in Releases 2.3.0 added

#3 Updated by Shira Maximov 5 months ago

  • Status changed from Ready For Testing to Closed

#4 Updated by The Foreman Bot 5 months ago

  • Pull request https://github.com/theforeman/foreman/pull/7975 added

Also available in: Atom PDF