Project

General

Profile

Bug #30039

Host - Registered Content Hosts report: "Safemode doesn't allow to access 'report_hraders' on #<Safemode::ScopeObject>"

Added by Tomer Brisker 5 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Reporting
Target version:
-
Difficulty:
trivial
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1843846

Description of problem:
Registered Content Hosts report template contains typo "report_hraders" which causes rendering to fail with error "Safemode doesn't allow to access 'report_hraders' on #<Safemode::ScopeObject>".

How reproducible:
Deterministic

Steps to Reproduce:
1. Generate "Host - Registered Content Hosts" report

Actual results:
Error, nothing generated

Expected results:
Successfully generated report


Related issues

Related to Foreman - Bug #28637: An empty report file doesn't show any headers Closed

Associated revisions

Revision 5048c9fa (diff)
Added by Marek Hulán 5 months ago

Fixes #30039 - fix macro typo

History

#1 Updated by Tomer Brisker 5 months ago

  • Difficulty set to trivial
  • Category changed from Statistics to Reporting
  • Description updated (diff)

#2 Updated by Tomer Brisker 5 months ago

  • Related to Bug #28637: An empty report file doesn't show any headers added

#3 Updated by The Foreman Bot 5 months ago

  • Assignee set to Marek Hulán
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/community-templates/pull/744 added

#4 Updated by The Foreman Bot 5 months ago

  • Fixed in Releases 2.2.0 added

#5 Updated by Tomer Brisker 5 months ago

  • Fixed in Releases 2.1.0 added
  • Fixed in Releases deleted (2.2.0)

#6 Updated by Marek Hulán 5 months ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF