Project

General

Profile

Bug #30083

Applicability for obsoleting package

Added by Gerald Vogt almost 2 years ago. Updated almost 2 years ago.

Status:
New
Priority:
Normal
Assignee:
Category:
Repositories
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

It seems applicability/updateable packages are not recognized if it is obsoleting another package. One of the latest sync from postgresql repositories has a new version of libpq5 which replaces libpq on CentOS 8.

# dnf check-update
Updating Subscription Management repositories.
CentOS-8 - PowerTools                            76 kB/s | 2.5 kB     00:00    
CentOS-8 - Base                                  67 kB/s | 2.1 kB     00:00    
CentOS-8 - Extras                                68 kB/s | 2.1 kB     00:00    
CentOS-8 - AppStream                             83 kB/s | 2.5 kB     00:00    
Extra Packages for Enterprise Linux 8 - x86_64   73 kB/s | 2.4 kB     00:00    
Puppet 6 Repository el 8 - x86_64                58 kB/s | 1.8 kB     00:00    
Foreman client 2.0 el8                           67 kB/s | 2.1 kB     00:00    
Extra Packages for Enterprise Linux Modular 8 -  77 kB/s | 2.5 kB     00:00    
PostgreSQL 12 for RHEL/CentOS 8 - x86_64         68 kB/s | 2.1 kB     00:00    
PostgreSQL common RPMs for RHEL/CentOS 8 - x86_  70 kB/s | 2.1 kB     00:00    
Obsoleting Packages
libpq5.x86_64           12.3-10PGDG.rhel8        DKRZ_postgresql_pgdg-common-el8
    libpq.x86_64        12.1-3.el8               @AppStream                     

However, installable updates count on the content hosts page shows 0 available updates.

History

#1 Updated by Chris Roberts almost 2 years ago

  • Assignee set to Partha Aji

#2 Updated by Samir Jha almost 2 years ago

  • Triaged changed from No to Yes
  • Target version set to Katello Backlog

Also available in: Atom PDF