Project

General

Profile

Actions

Bug #30162

open

Allow newer Net::SSH

Added by Evgeni Golov about 4 years ago. Updated about 4 years ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
Packaging
Target version:
-
Difficulty:
Triaged:
No
Fixed in Releases:
Found in Releases:

Description

Ohai,

we currently pin Net::SSH to 4.2.0 as newer versions were not compatible with Fog (see https://projects.theforeman.org/issues/26024). It would be good re re-evaluate the situation and maybe unpin the version, so that the 5.x releases can be used.

Background: Foreman on EL8 is currently not installable when you have EPEL enabled, as EPEL ships a newer Net::SSH gem.


Related issues 1 (0 open1 closed)

Related to Foreman - Bug #26024: Remove fog and set fog-core to 2.1.0 and net-ssh to '4.2.0'ClosedKavita GaikwadActions
Actions #1

Updated by Evgeni Golov about 4 years ago

  • Related to Bug #26024: Remove fog and set fog-core to 2.1.0 and net-ssh to '4.2.0' added
Actions #2

Updated by Evgeni Golov about 4 years ago

I think this should be fixed in fog-core git (see https://github.com/fog/fog-core/pull/253/files) and we just need a new fog-core release?

Actions #3

Updated by Kavita Gaikwad about 4 years ago

As `fog-google` is having dependency on fog-core "<= 2.1.0", that's why currently fog-core is pointing to 2.1.0.
To update fog-core version, it may requires changes on fog-google side.

Actions #4

Updated by Tomer Brisker about 4 years ago

  • Category set to Packaging
Actions

Also available in: Atom PDF