Project

General

Profile

Bug #30179

The display of the time passed is not correct in some places, and shows a future time

Added by Richard Stempfl almost 2 years ago. Updated over 1 year ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Web UI
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

If you sync a repo and have a different timezone in the browser than the on the host, the wrong time is displayed in some places.
For example, here the repository is succsesfully synced in 56 minutes.

Screenshot_20200604_112255.png View Screenshot_20200604_112255.png 45.9 KB Richard Stempfl, 07/02/2020 05:58 AM
Screenshot_20200604_112209.png View Screenshot_20200604_112209.png 74.8 KB Richard Stempfl, 07/02/2020 05:58 AM
Screenshot_20200604_111320.png View Screenshot_20200604_111320.png 49.6 KB Richard Stempfl, 07/02/2020 05:58 AM
Screenshot 20200604 112255 Screenshot 20200604 112209 Screenshot 20200604 111320

History

#1 Updated by James Jeffers almost 2 years ago

  • Status changed from New to Need more information

Richard,

Can you elaborate on the comment "For example, here the repository is succsesfully synced in 56 minutes." - was there an example that did not make it into the description?

Thanks!

#2 Updated by Ian Ballou almost 2 years ago

Richard,

Are you still having this issue? We will be closing the bug in a week if we don't hear back.

#3 Updated by Richard Stempfl almost 2 years ago

  • File Screenshot_20200702_075227.png added

I have added a picture.

It seems to be katello-related

#4 Updated by Richard Stempfl almost 2 years ago

  • File deleted (Screenshot_20200702_075227.png)

#6 Updated by John Mitsch almost 2 years ago

  • Triaged changed from No to Yes
  • Target version set to Katello 4.0.0
  • Category set to Web UI

#7 Updated by Chris Roberts almost 2 years ago

  • Target version changed from Katello 4.0.0 to Katello 3.17.0

#8 Updated by James Jeffers over 1 year ago

Richard,

Can you indicate the timezone settings on the katello host vs the timezone setting of the browser?

Also, are you setting the brower timezone via the user account settings in the UI?

#9 Updated by Richard Stempfl over 1 year ago

Timezone in user settings is the browser default.

Timezones are both CEST

#10 Updated by James Jeffers over 1 year ago

I haven't been able to reproduce this so far on 3.18.pre-master, so I'll try with an earlier katello release.

I have tried using timezones of Europe/Berlin for the client browswer, user setting, and katello host.

I have also tried timezone of Europe/Berlin for the client browser and user setting, and America/New_York for the katello host.

If there is a particular detail I have missed, please let me know.

#11 Updated by Chris Roberts over 1 year ago

  • Target version changed from Katello 3.17.0 to Katello 3.18.0

#12 Updated by Justin Sherrill over 1 year ago

  • Target version changed from Katello 3.18.0 to Katello Recycle Bin
  • Status changed from Need more information to Rejected

Closing due to inactivity. Feel free to contact us if you're able to provide any feedback.

Also available in: Atom PDF