Project

General

Profile

Bug #30193

installer failed with error "Could not find a suitable provider for foreman_smartproxy" while doing upgrade

Added by Evgeni Golov 4 months ago. Updated 4 months ago.


Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1846593

Description of problem: Satellite-installer failed with error "Could not find a suitable provider for foreman_smartproxy" while doing upgrade from 6.7 to 6.8

Version-Release number of selected component (if applicable):
6.8 Snap4

How reproducible:
always

Steps to Reproduce:
1. Prepared the environment to perform the satellite-upgrade from 6.7 to 6.8
2. Configure all the repository(Enabled the required repository)
3. Execute the pre-check and it has completed successfully.

Actual results:

Satellite-installer failed with Could not find a suitable provider for foreman_smartproxy

Expected results:
Satllite-installer should not be failed.

Additional info:

Associated revisions

Revision 6e1a07bc (diff)
Added by Evgeni Golov 4 months ago

Fixes #30193 - move version unlock to main pre_validations hooks

hooks/pre_validations/31-puppet-agent-oauth.rb tries to re-install
puppet-agent-oauth, but for that to work the packages need to be
unlocked first

it's not sufficient to move it to katello/hooks/pre_validations as those
are executed after all main pre_validations

Revision 3e4ad778 (diff)
Added by Evgeni Golov 4 months ago

Fixes #30193 - execute rpm commands outside the SCL

otherwise Ruby finds the SCL oauth gem and does not re-install the one
for the AIO Puppet Ruby

Revision 06aaaefe (diff)
Added by Evgeni Golov 4 months ago

Fixes #30193 - status is now a boolean

Revision 2cfd0523 (diff)
Added by Evgeni Golov 4 months ago

Refs #30193 - always execute commands outside the SCL context

Revision 6a5daf8c (diff)
Added by Ewoud Kohl van Wijngaarden 4 months ago

Refs #30193 - Correct version locking

6e1a07bc35bfe97927dfac6477a1faf53092c58f moved version locking from
Katello to the common hooks. This was unintentional and should have been
kept for Katello, at least for now.

However, it did try to fix a real issue where yum was locked while the
hooks tried to make changes. However, during pre_validations it may
still find an issue and roll back so no changes should be made. To solve
this, the hook is moved to pre. This is more correct because at this
point Kafo, has committed all the answers and is going to make changes
to the system using Puppet.

History

#1 Updated by Evgeni Golov 4 months ago

  • Subject changed from Satellite-installer failed with error "Could not find a suitable provider for foreman_smartproxy" while doing upgrade from 6.7 to 6.8 to Satellite-installer failed with error "Could not find a suitable provider for foreman_smartproxy" while doing upgrade from 6.7 to 6.8
  • Project changed from Foreman to Installer

#2 Updated by The Foreman Bot 4 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman-installer/pull/524 added

#3 Updated by The Foreman Bot 4 months ago

  • Fixed in Releases 2.2.0 added

#4 Updated by Evgeni Golov 4 months ago

  • Status changed from Ready For Testing to Closed

#5 Updated by The Foreman Bot 4 months ago

  • Pull request https://github.com/theforeman/foreman-installer/pull/526 added

#6 Updated by The Foreman Bot 4 months ago

  • Pull request https://github.com/theforeman/foreman-installer/pull/527 added

#7 Updated by The Foreman Bot 4 months ago

  • Pull request https://github.com/theforeman/foreman-installer/pull/528 added

#8 Updated by Tomer Brisker 4 months ago

  • Target version set to 2.1.0

#9 Updated by Evgeni Golov 4 months ago

  • Fixed in Releases 2.1.0 added

#10 Updated by The Foreman Bot 4 months ago

  • Pull request https://github.com/theforeman/foreman-installer/pull/529 added

#11 Updated by Tomer Brisker 4 months ago

  • Fixed in Releases deleted (2.2.0)

#12 Updated by Tomer Brisker 4 months ago

  • Subject changed from Satellite-installer failed with error "Could not find a suitable provider for foreman_smartproxy" while doing upgrade from 6.7 to 6.8 to installer failed with error "Could not find a suitable provider for foreman_smartproxy" while doing upgrade

#13 Updated by The Foreman Bot 4 months ago

  • Pull request https://github.com/theforeman/foreman-installer/pull/530 added

#14 Updated by The Foreman Bot 4 months ago

  • Pull request https://github.com/theforeman/foreman-installer/pull/531 added

Also available in: Atom PDF