Project

General

Profile

Feature #30247

Option "Destroy associated VM on host delete" should be disabled by default.

Added by Marek Hulán 5 months ago. Updated 3 months ago.

Status:
Closed
Priority:
High
Assignee:
Category:
Inventory
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1804669

Description of problem:
This is really important, some times we get scenario where some content hosts were removed from vCenter after the customer just remove the CH from Satellite webUI. We already know the warning, however, the customer believes that will be related only to Satellite webUI. This feature is really interesting, however, should be disabled by default and once the customer is aware of how this work, they could switch easily.

Version-Release number of selected component (if applicable):
6.7

How reproducible:
100%

Steps to Reproduce:
1. Configure the Compute Resource
2. Create a new VM
3. Delete the CH via Satellite webUI

Actual results:
The machine will be removed from vCenter (or external virtualization resource)

Expected results:
Remove only from Satellite side (db, webUI)

Additional info:

Associated revisions

Revision f6fdaaf5 (diff)
Added by Marek Hulán 5 months ago

Fixes #30247 - do not delete VMs by default

We've seen multiple users deleting their VMs when they deleted host in
Foreman. That still seems to be very unexpected especially in case of
unmanaged hosts. It's safer to keep the VM and delete it only if users
explicitly want to.

This changes the default behavior and we'll need to cover that in
release notes. However it probably causes less pain than having VMs
running and consuming resources, when people forget to destroy them.

History

#1 Updated by The Foreman Bot 5 months ago

  • Assignee set to Marek Hulán
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/7789 added

#2 Updated by Marek Hulán 5 months ago

  • Status changed from Ready For Testing to Closed

#3 Updated by Tomer Brisker 4 months ago

  • Fixed in Releases 2.2.0 added

#4 Updated by The Foreman Bot 3 months ago

  • Pull request https://github.com/theforeman/foreman/pull/7975 added

Also available in: Atom PDF