Project

General

Profile

Bug #30329

Viewing errata from a repository returns incorrect unfiltered results

Added by Ian Ballou 4 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Errata Management
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1782426

Description of problem:

Viewing errata from a repo page provides unfiltered errata for the whole katello server, as opposed to the "<n> errata" that were presented as a link.

Version-Release number of selected component (if applicable):

Katello 3.12

How reproducible: Always, Easily

Steps to Reproduce:
1. Navigate to a repository that has some errata associated to it:
Content -> Products -> select a repo

2. On the right side under Content Counts, click the Errata link with a specific (integer) number of errata displayed. (example "228 errata" for my "Red Hat Enterprise Linux 8 for x86_64 - BaseOS RPMs x86_64 8" repo)

Actual results: You are taken to the basic errata page with no search results or filter for the selected repo, instead showing all errata in the satellite as a whole.

Expected results: Takes you to a page showing only errata relevant to the selected repo, or filtered to the repo to match the results

Additional info:

Compare the above behavior to the same action but click the "<n> Packages" link next to the repo, which does provide a resulting page with a scoped search.

Associated revisions

Revision e367b89e (diff)
Added by Ian Ballou 3 months ago

Fixes #30329 - Errata filters lost when viewing from repo (#8812)

History

#1 Updated by Ian Ballou 4 months ago

  • Subject changed from Viewing errata from a repository returns incorrect unfiltered results to Viewing errata from a repository returns incorrect unfiltered results

On master, and using recent versions of Firefox and Chromium, this issue only occurs if I middle click on the link or select "open in new tab".

#2 Updated by Ian Ballou 4 months ago

The issue definitely exists on 3.12, even without middle clicking the proper filtering is not applied. It could be related to the fact that the "Applicable" tick box is checked by default for 3.12.

#3 Updated by Ian Ballou 4 months ago

Similar issue: https://projects.theforeman.org/issues/29398

This is what fixed the issue originally. Note that the PR for this issue above did not fix the "open in new tab" issue.

#4 Updated by Ian Ballou 4 months ago

This issue will be used to fix the "new tab" problem alone since the rest of the problem is a duplicate of the redmine I linked above.

#5 Updated by The Foreman Bot 4 months ago

  • Assignee set to Ian Ballou
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/8812 added

#6 Updated by John Mitsch 4 months ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.16.0

#7 Updated by The Foreman Bot 3 months ago

  • Fixed in Releases Katello 4.0.0 added

#8 Updated by Anonymous 3 months ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF