Project

General

Profile

Bug #30425

Clicking on any other tab other than overview while on capsule synchronizing page, redirects to overview page.

Added by Justin Sherrill 3 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Category:
Foreman Proxy Content
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1856370

Description of problem:
Clicking on any other tab other than overview while on capsule synchronizing page, automatically redirects to overview page within seconds.

Version-Release number of selected component (if applicable):
Satellite 6.8.0

How reproducible:
Always

Steps to Reproduce:
1. Create custom product with any upstream repo url
2. Create lifecycle environment -> create content view -> (optional) create activation key
3. Install capsule. Goto Infrastructure -> Capsule -> open the capsule installed -> attach lifecycle environment to the capsule -> Start any of the synchronization method.
4. Try opening any of the tabs(ex: Logs) other than Overview.

Actual results:
Within seconds of clicking, you'll be redirected to Overview page.

Expected results:
Redirection should not occur when viewing any of the tab.

Additional info:
Step 4 to be executed while the syncing is in process.

Associated revisions

Revision afb8e562 (diff)
Added by Justin Sherrill 3 months ago

Fixes #30425 - fix page redirect during smart proxy sync

This was likely caused by the recent upgrade to angular,
although the exact root cause is not fully clear. I believe
this code was meant to handle a link to a smart proxy page from
another bastion page, however this did not even work on older
builds (where this bug was not present). No such links exist
today, but if you try to add one, it will not work.

Thus this change does not cause any regressions, but if we
ever add a link to the smart proxy details page from a bastion page
it will (still) not redirect to that page.

History

#1 Updated by The Foreman Bot 3 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/8841 added

#2 Updated by Chris Roberts 3 months ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.16.0

#3 Updated by The Foreman Bot 3 months ago

  • Fixed in Releases Katello 3.18.0 added

#4 Updated by Justin Sherrill 3 months ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF