Project

General

Profile

Bug #30472

Error while running katello:pulp3_migration

Added by Suraj Patil almost 2 years ago. Updated over 1 year ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Getting error "Only one migration plan can run at a time" when executing katello:pulp3_migration.

[root@katello-1 ~]# foreman-rake katello:pulp3_migration
rake aborted!
ForemanTasks::TaskError: Task 55f18cd7-61b9-4433-b316-67c2631f3001: Dynflow::Errors::UnknownError[Pulp2to3MigrationClient::ApiError]: Error message: the server returns an error
HTTP status code: 400
Response headers: {"date"=>"Wed, 22 Jul 2020 07:10:41 GMT", "server"=>"gunicorn/20.0.4", "content-type"=>"application/json", "vary"=>"Accept", "allow"=>"POST, OPTIONS", "x-frame-options"=>"SAMEORIGIN", "content-length"=>"45", "via"=>"1.1 katello-2.example.com", "connection"=>"close"}
Response body: ["Only one migration plan can run at a time"]
/opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.16.0.rc4.1/lib/katello/tasks/pulp3_migration.rake:15:in `block (2 levels) in <top (required)>'
/opt/rh/rh-ruby25/root/usr/share/gems/gems/rake-12.3.0/exe/rake:27:in `<top (required)>'
Tasks: TOP => katello:pulp3_migration
(See full trace by running task with --trace)

It looks like pulp restricts to run multiple migration plan at the same time. https://pulp.plan.io/issues/6639

But katello is triggering API to run all the migration plan at once. https://github.com/Katello/katello/blob/64f9d6a7dfcf4347ec8937ecf42642adfbed8512/app/services/katello/pulp3/migration.rb#L46

Httpd logs -

192.168.123.4 - - [22/Jul/2020:12:40:39 +0530] "POST /pulp/api/v3/migration-plans/ HTTP/1.1" 201 461 "-" "OpenAPI-Generator/0.2.0b2/ruby" 
192.168.123.4 - - [22/Jul/2020:12:40:40 +0530] "POST /pulp/api/v3/migration-plans/ HTTP/1.1" 201 184 "-" "OpenAPI-Generator/0.2.0b2/ruby" 
192.168.123.4 - - [22/Jul/2020:12:40:40 +0530] "POST /pulp/api/v3/migration-plans/d0262efb-297f-4b07-ba05-6a17a389b921/run/ HTTP/1.1" 202 67 "-" "OpenAPI-Generator/0.2.0b2/ruby" 
192.168.123.4 - - [22/Jul/2020:12:40:41 +0530] "POST /pulp/api/v3/migration-plans/64967a33-7163-4b87-b305-67b21b66ac89/run/ HTTP/1.1" 400 45 "-" "OpenAPI-Generator/0.2.0b2/ruby" 

Related issues

Related to Katello - Feature #29959: Support yum migration for pulp3Closed
Is duplicate of Katello - Bug #30540: Run a single migration instead of multiple for pulp3Closed

History

#1 Updated by Chris Roberts almost 2 years ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.16.0

#2 Updated by Ian Ballou almost 2 years ago

#3 Updated by Justin Sherrill almost 2 years ago

  • Is duplicate of Bug #30540: Run a single migration instead of multiple for pulp3 added

#4 Updated by Justin Sherrill almost 2 years ago

  • Status changed from New to Duplicate

#5 Updated by Chris Roberts over 1 year ago

  • Target version changed from Katello 3.16.0 to Katello Recycle Bin

Also available in: Atom PDF