Project

General

Profile

Bug #30529

foreman-maintain backup fails

Added by Suraj Patil 3 months ago. Updated 3 months ago.

Status:
Duplicate
Priority:
High
Assignee:
Category:
Procedure
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Foreman maintain backup fails with the below error.

[root@katello-2 foreman_maintain]# ./bin/foreman-maintain backup offline /tmp/
Starting backup: 2020-07-30 13:09:05 +0530
Running preparation steps required to run the next scenarios
================================================================================
Make sure Foreman DB is up: 
/ Checking connection to the Foreman DB                               [OK]      
--------------------------------------------------------------------------------

Running Backup
================================================================================
Confirm turning off services is allowed: 
WARNING: This script will stop your services.

Do you want to proceed?, [y(yes), q(quit)] y
                                                                      [OK]      
--------------------------------------------------------------------------------
Prepare backup Directory: 
Creating backup folder /tmp/foreman-backup-2020-07-30-13-09-05        [FAIL]
Either  or /*.snar files unavailable. Provide a valid previous backup directory
--------------------------------------------------------------------------------
Scenario [Backup] failed.

The following steps ended up in failing state:

  [backup-prepare-directory]

Resolve the failed steps and rerun
the command. In case the failures are false positives,
use --whitelist="backup-prepare-directory" 


Related issues

Is duplicate of Foreman Maintain - Bug #30369: foreman-maintain incremental backup takes the full backup.Closed

History

#1 Updated by The Foreman Bot 3 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman_maintain/pull/380 added

#2 Updated by Kavita Gaikwad 3 months ago

  • Is duplicate of Bug #30369: foreman-maintain incremental backup takes the full backup. added

#3 Updated by Kavita Gaikwad 3 months ago

  • Status changed from Ready For Testing to Duplicate

Also available in: Atom PDF