Project

General

Profile

Bug #30550

Unable to create compute profile for specific vmware compute resource

Added by Shira Maximov almost 2 years ago. Updated 4 months ago.

Status:
Duplicate
Priority:
High
Assignee:
-
Category:
Compute resources - VMware
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1856626

Unable to create a compute profile for a specific vmware compute resource. The compute resource is a vmware 6.5U2 cluster connecting via vsphere 6.7U3. When trying to create the compute profile, receiving the following error message:
Oops, we're sorry but something went wrong undefined method `gsub' for nil:NilClass

ActionView::Template::Error
undefined method `gsub' for nil:NilClass
/usr/share/foreman/app/models/concerns/fog_extensions/vsphere/folder.rb:6:in `to_label'
/opt/theforeman/tfm-ror52/root/usr/share/gems/gems/actionview-5.2.1/lib/action_view/helpers/form_options_helper.rb:805:in `value_for_collection'

a suggested fix in the customer case:
Edit the file:

path.slice((path.index(datacenter) + datacenter.length + 1)..-1).gsub('/', ' / ')

Try changing to

path.slice((path.index(datacenter) + datacenter.length + 1)..-1).to_s.gsub('/', ' / ')

Restart the Satellite services.

  1. katello-service restart

Now try to make changes to the Compute profile and share us your observations.


Related issues

Is duplicate of Foreman - Bug #28155: Cannot view Compute-Profiles from a specific Compute-ResourceClosed

Associated revisions

Revision 951efe8a (diff)
Added by Bernhard Suttner 5 months ago

Fixes #30550,#28155 - Return valid vsphere folder (#9006)

History

#1 Updated by Ondřej Ezr 5 months ago

  • Bugzilla link deleted (1856626)
  • Status changed from New to Duplicate
  • Subject changed from Unable to create compute profile for specific vmware compute resource to Unable to create compute profile for specific vmware compute resource

Dup of #28155

#2 Updated by Ondřej Ezr 5 months ago

  • Is duplicate of Bug #28155: Cannot view Compute-Profiles from a specific Compute-Resource added

#3 Updated by The Foreman Bot 5 months ago

  • Fixed in Releases 3.2.0 added

#4 Updated by Ewoud Kohl van Wijngaarden 4 months ago

  • Triaged changed from No to Yes
  • Target version set to 3.1.1
  • Fixed in Releases 3.1.1 added

Also available in: Atom PDF