Project

General

Profile

Bug #30589

Inconsistent input format for foreman-maintain packages install/update command.

Added by Kavita Gaikwad 3 months ago. Updated about 2 months ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1860804

Description of problem:
Inconsistent input format for foreman-maintain packages install/update command.

Version-Release number of selected component (if applicable):
- Satellite 6.8.0 snap 9
- rubygem-foreman_maintain-0.6.8-1.el7sat.noarch

How reproducible:
Always

Steps to Reproduce:
  1. foreman-maintain packages install rubygem-foreman_maintain,zsh
    Running install packages in unlocked session ================================================================================
    Install packages: Loaded plugins: foreman-protector, product-id, search-disabled-repos, subscription-manager
    Sat6-CI_Red_Hat_Satellite_6_7_Composes_Satellite_6_7_RHEL7 | 2.5 kB 00:00:00
    Sat6-CI_Red_Hat_Satellite_6_7_Composes_Satellite_Tools_6_7_RHEL7 | 2.1 kB 00:00:00
    Sat6-CI_Red_Hat_Satellite_6_8_Composes_Satellite_6_8_RHEL7 | 2.5 kB 00:00:00
    Sat6-CI_Red_Hat_Satellite_6_8_Composes_Satellite_Tools_6_8_RHEL7 | 2.1 kB 00:00:00

WARNING: Excluding 12664 packages due to foreman-protector.
Use foreman-maintain packages install/update <package>
to safely install packages without restrictions.
Use foreman-maintain upgrade run for full upgrade.

No package rubygem-foreman_maintain,zsh available.
Error: Nothing to do
[WARNING]
Failed executing yum install rubygem-foreman_maintain,zsh, exit status 1
--------------------------------------------------------------------------------
Scenario [install packages in unlocked session] failed.

The following steps ended up in warning state:

[packages-install]

The steps in warning state itself might not mean there is an error,
but it should be reviewed to ensure the behavior is expected

[root@dhcp-3-115 foreman_maintain]# foreman-maintain packages update rubygem-foreman_maintain,zsh
ERROR: install or update 'rubygem-foreman_maintain' package individually.
[root@dhcp-3-115 foreman_maintain]# foreman-maintain packages update rubygem-foreman_maintain zsh
ERROR: too many arguments

See: 'foreman-maintain packages update --help'
[root@dhcp-3-115 foreman_maintain]# foreman-maintain packages install rubygem-foreman_maintain zsh
ERROR: install or update 'rubygem-foreman_maintain' package individually.

  1. foreman-maintain packages update rubygem-foreman_maintain, zsh
    ERROR: too many arguments

See: 'foreman-maintain packages update --help'

  1. foreman-maintain packages install rubygem-foreman_maintain, zsh
    ERROR: install or update 'rubygem-foreman_maintain' package individually.

Actual results:
foreman-maintain packages install and update command treats same package list input differently.

Expected results:
Consistent/same package input format for foreman-maintain packages install/update command.

Additional info:

Associated revisions

Revision 3a327975 (diff)
Added by Kavita Gaikwad about 2 months ago

Fixes #30589 - make packages update & install commands consistent

History

#1 Updated by Kavita Gaikwad 3 months ago

  • Assignee changed from Anurag Patel to Kavita Gaikwad

#2 Updated by The Foreman Bot 3 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman_maintain/pull/384 added

#3 Updated by Kavita Gaikwad about 2 months ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF