Project

General

Profile

Bug #30685

Run action is missing in job templates page

Added by Adam Ruzicka almost 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
-

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1866461

Description of problem: Run action is missing at job template index page

Version-Release number of selected component (if applicable): Satellite 6.8

How reproducible: Always

Steps to Reproduce:
1. Go to Hosts -> Job Templates
2. "Run" is missing in Action column

Actual results: "Run" action is missing

Expected results: Should be able run job template

Additional info:
[root@dhcp131-3 ~]# rpm -qa satellite
satellite-6.8.0-0.7.beta.el7sat.noarch
rp[root@dhcp131-3 ~]# rpm -qa foreman
foreman-2.1.0.1-1.el7sat.noarch
[root@dhcp131-3 ~]# rpm -qa katello
katello-3.16.0-0.4.rc4.el7sat.noarch

Associated revisions

Revision 2efd0a6e (diff)
Added by Adam Ruzicka almost 2 years ago

Fixes #30685 - Ensure run button appears in job templates page

Due to how Rails load code, it could happen that the module with extensions
would get prepended too late and it would be ignored. By prepending the
extensions from an initializer we make it happen earlier in the boot process.

History

#1 Updated by The Foreman Bot almost 2 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman_remote_execution/pull/531 added

#2 Updated by The Foreman Bot almost 2 years ago

  • Fixed in Releases added

#3 Updated by Adam Ruzicka almost 2 years ago

  • Status changed from Ready For Testing to Closed

#4 Updated by Adam Ruzicka almost 2 years ago

  • Subject changed from Run action is missing in job templates page to Run action is missing in job templates page
  • Fixed in Releases foreman_remote_execution 3.3.7 added

#5 Updated by Adam Ruzicka almost 2 years ago

  • Fixed in Releases foreman_remote_execution 4.1.0 added
  • Fixed in Releases deleted (foreman_remote_execution 3.3.7)

#6 Updated by Adam Ruzicka almost 2 years ago

  • Fixed in Releases foreman_remote_execution 3.3.7 added

Also available in: Atom PDF