Project

General

Profile

Bug #30697

Pulpcore database created with SQL_ASCII encoding

Added by Ian Ballou about 2 years ago. Updated almost 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Foreman modules
Target version:
-
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

A user's pulpcore database was created with SQL_ASCII encoding instead of UTF-8. This caused sync errors with Pulp 3. I'm not positive that this would be an installer issue, but it seems plausible.

Here is the originally thread: https://community.theforeman.org/t/unable-to-sync-repo-encoding-error/20179

Installed Katello version: 3.16


Related issues

Is duplicate of Installer - Bug #31018: Pulpcore PostgreSQL database is not enforced to UTF-8Closed

History

#1 Updated by Ian Ballou about 2 years ago

Installer command used to install Katello:

foreman-installer --enable-foreman-plugin-ansible --enable-foreman-proxy-plugin-ansible --enable-foreman-plugin-remote-execution --enable-foreman-proxy-plugin-remote-execution-ssh --scenario katello

#3 Updated by Ewoud Kohl van Wijngaarden almost 2 years ago

  • Status changed from New to Duplicate

I am bad at checking for an existing issue and created #31018.

#4 Updated by Ewoud Kohl van Wijngaarden almost 2 years ago

  • Is duplicate of Bug #31018: Pulpcore PostgreSQL database is not enforced to UTF-8 added

Also available in: Atom PDF