Project

General

Profile

Bug #30706

Creating compute resources on IPV6 network does not fail gracefully

Added by Tomer Brisker about 2 months ago. Updated about 1 month ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
VM management
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1858855

Description of problem:
I know that one of the requirements is that IPv6 doesn't support compute resources, but when you try to create one, it doesn't fail gracefully.

Version-Release number of selected component (if applicable):
6.8.0_snap 9

How reproducible:
100%

Steps to Reproduce:
1. Have all ipv6 connection setup.
2. Create proxy on firefox to access UI
3. Login on UI, Infrastructure -> Compute Resources
4. Select EC2 from dropdown menu and fill in all necessary info
5. Click submit.

Actual results:
Oops, we're sorry but something went wrong Network is unreachable - connect(2) for <ip> (Errno::ENETUNREACH)

Expected results:
At least stay on satellite with a better error message.

Additional info:
Any compute resources provider fails the same way. Is there a way we make this error handle better on the UI?

Associated revisions

Revision c6361ee8 (diff)
Added by Tomer Brisker about 2 months ago

Fixes #30706 - Gracefully recover from CR connection error

If the connection fails to the compute resource due to networking
issues we should capture it nicely rather than causing a 500 page.

History

#1 Updated by Lukas Zapletal about 2 months ago

What else is Foreman supposed to print out? Foreman can't reach the destination. We throw the very same message at about 50+ other places.

#2 Updated by The Foreman Bot about 2 months ago

  • Assignee set to Tomer Brisker
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/7952 added

#3 Updated by The Foreman Bot about 2 months ago

  • Fixed in Releases 2.3.0 added

#4 Updated by Tomer Brisker about 2 months ago

  • Status changed from Ready For Testing to Closed

#5 Updated by The Foreman Bot about 2 months ago

  • Pull request https://github.com/theforeman/foreman/pull/7940 added

#6 Updated by The Foreman Bot about 1 month ago

  • Pull request https://github.com/theforeman/foreman/pull/7975 added

Also available in: Atom PDF