Project

General

Profile

Bug #30708

Syspurpose role is showing empty in the subscription page and rest api even it has a role

Added by Hao Yu over 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Category:
Subscriptions
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Description of problem:
Go to Web UI -> Content -> Subscriptions -> pick a subscription with role, "Red Hat Enterprise Linux Server with Smart Management, Premium (Physical or Virtual Nodes)" is a good candidate -> Details tab

Under "System Purpose" section, role is empty.

You can also reproduce via rest api:

curl -v -k -u "username:password" https://satellite.example.com/katello/api/organizations/1/subscriptions/<subscription id> | python -m json.tool {
...
"roles": null, <================== Role is null
"support_level": "Premium",
"support_type": "L1-L3",
"type": "NORMAL",
...
"usage": "Production",
...
}

Additional info:

It is because of the "s" word (plural). Candlepin calls it roles but Katello calls it role.

See the below lines in "glue/candlepin/pool.rb" for more details:

lazy_accessor :pool_derived, :owner, :source_pool_id, :virt_limit, :arch, :description, :product_family,
:variant, :suggested_quantity, :support_type, :product_id, :type, :upstream_entitlement_id, :roles, :usage, :addons,
:initializer => :pool_facts

Associated revisions

Revision bc682301 (diff)
Added by Jonathon Turel about 1 year ago

Fixes #30708 - Show syspurpose roles correctly in UI and API

History

#1 Updated by Jonathon Turel over 1 year ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.18.0

#2 Updated by Jonathon Turel over 1 year ago

  • Target version changed from Katello 3.18.0 to Katello 4.1.0

#3 Updated by Jonathon Turel about 1 year ago

  • Assignee set to Jonathon Turel

#4 Updated by The Foreman Bot about 1 year ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/9233 added

#5 Updated by The Foreman Bot about 1 year ago

  • Fixed in Releases Katello 4.2.0 added

#6 Updated by Jonathon Turel about 1 year ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF