Project

General

Profile

Bug #3072

Vmware: error listing VMs

Added by Angelo Lisco almost 9 years ago. Updated almost 9 years ago.

Status:
Closed
Priority:
Immediate
Category:
Compute resources
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

After adding a compute resource (vsphere 5.1.0) in foreman-nighly, I get this error trying to browse the virtual machines:

"There was an error listing VMs: undefined method `state' for #<FogExtensions::Vsphere::MiniServer:0x000000081fa538>"

System information:
Red Hat Enterprise 6.4 (x86_84)

Packages:
foreman-compute-1.2.9999-10.201309102143gitbc89eb3.el6.noarch
foreman-assets-1.2.9999-10.201309102143gitbc89eb3.el6.noarch
rubygem-foreman_api-0.1.6-1.el6.noarch
foreman-release-1.2.9999-9.201309091013git2b15ea6.el6.noarch
ruby193-rubygem-foremancli-1.0-6.el6.noarch
foreman-1.2.9999-10.201309102143gitbc89eb3.el6.noarch
foreman-vmware-1.2.9999-10.201309102143gitbc89eb3.el6.noarch
foreman-postgresql-1.2.9999-10.201309102143gitbc89eb3.el6.noarch
foreman-sqlite-1.2.9999-10.201309102143gitbc89eb3.el6.noarch
foreman-installer-1.2.9999-3.201309061614gite83c8c6.el6.noarch
foreman-cli-1.2.9999-10.201309102143gitbc89eb3.el6.noarch
foreman-proxy-1.3.9999-1.201309091626git296617a.el6.noarch


Related issues

Has duplicate Katello - Bug #4057: Foreman won't load VM's from vSphere 5Duplicate2014-01-16

Associated revisions

Revision f925e9f8 (diff)
Added by Martin Matuška almost 9 years ago

fixes #3072 Vmware: error listing VMs

Revision 7b2b5c77 (diff)
Added by Martin Matuška almost 9 years ago

fixes #3072 Vmware: error listing VMs

(cherry picked from commit f925e9f8f5a0d84dae01efeffcfd58604e276ca7)

History

#1 Updated by Dominic Cleal almost 9 years ago

  • Target version set to 1.3.0

Regression from 1.2 I think.

#2 Updated by Lukas Zapletal almost 9 years ago

So the target 1.3 means - we will focus on that and try to get it into 1.3 I guess. Okay.

#3 Updated by Angelo Lisco almost 9 years ago

Dominic Cleal wrote:

Regression from 1.2 I think.

Thank you Dominic for raising the importance of this bug.
Maybe it's a 'fog' regression from 1.2?

#4 Updated by Angelo Lisco almost 9 years ago

Find this one searching for Katello nighly bugs:
https://github.com/Katello/katello/issues/2936

#5 Updated by Dominic Cleal almost 9 years ago

Probably a regression due to us improving the power state support, maybe the vSphere provider doesn't expose the same methods.

#6 Updated by Dominic Cleal almost 9 years ago

  • Priority changed from Normal to Urgent

#7 Updated by Duncan Innes almost 9 years ago

I'm getting this too and happy to test when fixes available. I'm running against the katello-foreman repo though, so may be behind your efforts?

#8 Updated by Dominic Cleal almost 9 years ago

  • Status changed from New to Ready For Testing
  • Assignee set to Martin Matuška

https://github.com/theforeman/foreman/pull/893

There's a patch you can try on there Duncan, or nightly builds will be published to the Foreman yum repos later today after it's merged. Katello repos are refreshed from ours every few weeks I think.

#9 Updated by Dominic Cleal almost 9 years ago

  • Priority changed from Urgent to Immediate

#10 Updated by Martin Matuška almost 9 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#11 Updated by Duncan Innes almost 9 years ago

Applied patch(es) manually. Error is gone, but I only get 1 vGuest reporting back out of 232. Possibly my configuration?

#12 Updated by Lukas Zapletal almost 9 years ago

  • Related to Tracker #3112: [TRACKER] Issues to be released in 1.3 RC or final added

#13 Updated by Angelo Lisco almost 9 years ago

The patch works and i'm able to connect to our Vsphere infrastructure but I still can't see all the deployed vm's. I noticed that all the vms which are located in a 'vmware directory' are not visible.
Maybe it's another bug?

#14 Updated by Dominic Cleal almost 9 years ago

The folders issue is tracked in #2093, possibly that's what's causing Duncan's issue too.

#15 Updated by Duncan Innes almost 9 years ago

Yes - the server I'm listing is the only one not in a folder. Great. Will wait the resolution of #2093

#16 Updated by Duncan Innes almost 9 years ago

Actually, is there any way of poking #2093 up the priority list a bit? I've commented on it, but it looks unloved for a while. I've not worked on a site where VM folders are not used in some way, so this is a bigger issue than perhaps perceived at present.

#17 Updated by Dominic Cleal almost 9 years ago

If you can complete the attached patch and submit it, we can get it included in a future release. There's more information available on the website on getting started in the project (-dev IRC and mailing lists are also useful resources).

#18 Updated by Lukas Zapletal almost 9 years ago

  • Related to deleted (Tracker #3112: [TRACKER] Issues to be released in 1.3 RC or final)

#19 Updated by Dominic Cleal over 8 years ago

  • Has duplicate Bug #4057: Foreman won't load VM's from vSphere 5 added

Also available in: Atom PDF