Project

General

Profile

Bug #30721

Disable mongo Full Time Diagnostic Data Capture

Added by Eric Helms about 2 months ago. Updated about 2 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
foreman-installer script
Target version:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1834377

Description of problem:
By default, mongo collects FTDC (Full Time Diagnostic Data Capture). See https://docs.mongodb.com/manual/administration/analyzing-mongodb-performance/ and grep for FTDC. Checking thread CPU usage, I noticed that ftdc thread responsible for this consumes nontrivial amount of CPU. On idle-ish Satellite, it is the most busy thread, on a very busy Satellite, it consumes 5% of overall mongod CPU time.

We have not utilised the collected data under /var/lib/mongodb/diagnostic.data/ so we should disable collecting the FTDC by default and save 5%+ CPU time of mongod.

I understand mongod will be deprecated since Sat7, letting on PrdM and Eng to decide if it is worth disabling since then.

It is sufficient to change /etc/opt/rh/rh-mongodb34/sysconfig/mongod to:

OPTIONS="-f /etc/opt/rh/rh-mongodb34/mongod.conf --setParameter diagnosticDataCollectionEnabled=false"

Version-Release number of selected component (if applicable):
Sat 6.7

How reproducible:
100%

Steps to Reproduce:
1. Deploy a Sat, produce a load
2. /bin/ps -p $(pgrep mongod) -L -o pid,tid,psr,pcpu,comm= | sort -nk4

Actual results:
2. shows one of busiest threads is:
PID TID PSR %CPU
..
15086 15106 11 1.4 ftdc

Expected results:
ftdc does not consume CPU

Additional info:

Associated revisions

Revision 8164f23c (diff)
Added by Eric Helms about 2 months ago

Fixes #30721: Disable MongoDB diagnostic data collection

History

#1 Updated by The Foreman Bot about 2 months ago

  • Assignee set to Eric Helms
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman-installer/pull/567 added

#2 Updated by The Foreman Bot about 2 months ago

  • Fixed in Releases 2.3.0 added

#3 Updated by Eric Helms about 2 months ago

  • Status changed from Ready For Testing to Closed

#4 Updated by The Foreman Bot about 2 months ago

  • Pull request https://github.com/theforeman/foreman-installer/pull/574 added

#5 Updated by Ewoud Kohl van Wijngaarden about 2 months ago

  • Triaged changed from No to Yes
  • Target version set to 2.2.0
  • Category set to foreman-installer script
  • Fixed in Releases 2.2.0 added
  • Fixed in Releases deleted (2.3.0)

#6 Updated by Ewoud Kohl van Wijngaarden about 2 months ago

  • Subject changed from Disable mongo FTDC to Disable mongo Full Time Diagnostic Data Capture

Also available in: Atom PDF