Project

General

Profile

Bug #30736

Updating the CDN URL is manifest works fine but creates some tasks which remains in planned state with success result

Added by Justin Sherrill 3 months ago. Updated 2 months ago.

Status:
Closed
Priority:
Normal
Category:
Repositories
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1873408

Description of problem:

While verifying if the issue reported on "https://bugzilla.redhat.com/show_bug.cgi?id=1727493" is whether or not reproducible on Satellite 6.8 beta, It's being observed that whereas the issue is not reproducible but it creates some tasks at backend which stays in planned state even if the result is success for those tasks.

Version-Release number of selected component (if applicable):
satellite-6.8.0-0.7.beta.el7sat.noarch

How reproducible:
Always

Steps to Reproduce:
1. Content --> Subscriptions --> Manage Manifest
2. Change the CDN Url to point to "http://satellite.example.com/pub/sat-import/"
3. Click on Update.
4. Wait for few mins and Go back to Monitor --> Tasks
5. Search the tasks using this filter --> state != stopped && result = success

Actual results:

Number of tasks by the name "Updating repository authentication configuration" , label "Actions::Katello::Repository::UpdateCVRepoCertGuard " , stays in planned | stopped state.

  1. hammer task list --search "state != stopped && result = success"
    -------------------------------------|---------------------------------------------------|---------|---------|---------------------|----------|-------|------------
    ID | ACTION | STATE | RESULT | STARTED AT | ENDED AT | OWNER | TASK ERRORS
    -------------------------------------|---------------------------------------------------|---------|---------|---------------------|----------|-------|------------
    d70da815-dc7b-4ed4-a78c-5d5194932992 | Updating repository authentication configuration | planned | success | 2020/08/28 08:15:17 | | admin |
    8abfe90a-116c-4286-af27-78e2c548ff23 | Updating repository authentication configuration | planned | success | 2020/08/28 08:15:17 | | admin |
    0b009f5a-16fa-46ca-b50a-234484dcf590 | Updating repository authentication configuration | planned | success | 2020/08/28 08:15:17 | | admin |
    0c7585f9-208b-405e-9e08-ebddcda40a28 | Updating repository authentication configuration | planned | success | 2020/08/28 08:15:16 | | admin |
    -------------------------------------|---------------------------------------------------|---------|---------|---------------------|----------|-------|------------
  1. hammer task info --id d70da815-dc7b-4ed4-a78c-5d5194932992
    ID: d70da815-dc7b-4ed4-a78c-5d5194932992
    Action: Updating repository authentication configuration
    State: planned
    Result: success
    Started at: 2020/08/28 08:15:17
    Ended at:
    Owner: admin
    Task errors:

Expected results:

If a task is successfully completed, It should not stay in planned state or else attempt of upgrade to next available minor\major release will fail.

Additional info:

NA

Associated revisions

Revision d62fe7d2 (diff)
Added by Justin Sherrill 3 months ago

Fixes #30736 - refactor cert guard updating

previously when updating the CDN url, a task was triggered
to update each repository and as part of that to update cert guard
data. Due to a small logic bug, this was happening even when it should
not have been. But in addition to this, the place that it was triggered
could lead to tasks being left in pending state.

This refactor moves UpdateCvRepoCertGuard into a orchestration action,
which will optionally get called if the repo is pulp3. This means that under
pulp2, a repo will not have this action triggered for it at all saving some
computation.

History

#1 Updated by The Foreman Bot 3 months ago

  • Assignee set to Justin Sherrill
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/8912 added

#2 Updated by The Foreman Bot 3 months ago

  • Fixed in Releases Katello 4.0.0 added

#3 Updated by Justin Sherrill 3 months ago

  • Status changed from Ready For Testing to Closed

#4 Updated by Chris Roberts 3 months ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.16.1
  • Fixed in Releases Katello 3.16.1 added
  • Fixed in Releases deleted (Katello 4.0.0)

Also available in: Atom PDF