Project

General

Profile

Bug #30785

Missed slash at the end of the repos

Added by jeschero please_edit_me over 1 year ago. Updated over 1 year ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Repositories
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Hello,

i have a bug/problem with the repo url on the clients.

My enviroment:
- Centos 7
- Foreman 2.1
- Katello 3.16

I have create a product for Centos 7 and repository for this. After this i have create a content-view and an activation-key for this product.
Now add i a client and the registration is successful, but i can't install any programms.

Night a few tests i have found the problem:
subscription-manager create this url: "https://<hostname>/pulp/repos/<domain>/Library/CentOS7_CV/custom/CentOS7/CentOS7_OS", but in a browser i get the message "404: Not Found".
But if a add a slash at the end of the url (https://&lt;hostname&gt;/pulp/repos/&lt;domain&gt;/Library/CentOS7_CV/custom/CentOS7/CentOS7_OS/) i can see the repos in the browser and add i the slash in the redhat.repo i can install programs and update the system.
After a "subscription-manager refresh/subscription-manager repos --list" the subscription-manager remove the slash und i can't install programs and update.

History

#1 Updated by Samir Jha over 1 year ago

  • Status changed from New to Need more information

Hey Jeschero,

Is this a fresh 3.16 install?

#2 Updated by jeschero please_edit_me over 1 year ago

Samir Jha wrote:

Hey Jeschero,

Is this a fresh 3.16 install?

Hey Samir Jha,

yes, it is a fresh install.

#3 Updated by The Foreman Bot over 1 year ago

  • Assignee set to Partha Aji
  • Status changed from Need more information to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/8957 added

#4 Updated by Ian Ballou over 1 year ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.18.0

#5 Updated by Justin Sherrill over 1 year ago

  • Assignee deleted (Partha Aji)
  • Status changed from Ready For Testing to New
  • Pull request deleted (https://github.com/Katello/katello/pull/8957)

this had a pr accidentally associated with it, removing.

#6 Updated by Jonathon Turel over 1 year ago

  • Category set to Repositories

#7 Updated by Jonathon Turel over 1 year ago

  • Target version changed from Katello 3.18.0 to Katello Recycle Bin
  • Status changed from New to Rejected

Hello! We're not able to reproduce this problem in Katello 3.18 which has just been released. Would you be able to upgrade (3.16 -> 3.17 -> 3.18) and see if this issue goes away? You may need a subscription-manager refresh/repos on your client to regenerate the redhat.repo file

If you are still hitting the problem please start a thread in our support forum: https://community.theforeman.org/c/support/10

Also available in: Atom PDF