Project

General

Profile

Feature #30835

Storage domain from External provider not available when creating new host

Added by Shira Maximov about 1 year ago. Updated 7 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Compute resources - oVirt
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1757114

Description of problem:
RHV using an external provider as storage domain (Cinder). However, the Cinder storage domain is not available on Satellite when creating a new VM.

How reproducible:

Steps to Reproduce:
1. Configure a Cinder external provider on RHV
2. Configure RHV as a compute resource on Satellite
3. Try creating a new VM on RHV using Satellite, with a disk on the Cinder storage domain.

Actual results:
- Cinder storage domain is not listed in the list of available storage domains

Expected results:
- all storage domains available on the RHV should be available in Satellite when creating VMs.

Additional info:

Issue seems to be on ovirt model, which filters the storage domain by type, bringing only the ones of type "data", while cinder storage domain are of the type "volume".

See here:

~~
def storage_domains(opts = {})
client.storage_domains({:role => 'data'}.merge(opts))
end
~
~

source: https://github.com/theforeman/foreman/blob/develop/app/models/compute_resources/foreman/model/ovirt.rb#L234

Associated revisions

Revision 20e36a5a (diff)
Added by Shira Maximov 9 months ago

Fixes #30835 - ovirt Filter SD by data and volume

History

#1 Updated by The Foreman Bot about 1 year ago

  • Assignee set to Shira Maximov
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/8005 added

#2 Updated by The Foreman Bot 9 months ago

  • Fixed in Releases 2.4.0 added

#3 Updated by Shira Maximov 9 months ago

  • Status changed from Ready For Testing to Closed

#4 Updated by Tomer Brisker 7 months ago

  • Subject changed from - Storage domain from External provider not available when creating new host on Satellite to Storage domain from External provider not available when creating new host

Also available in: Atom PDF