Project

General

Profile

Bug #3084

Foreman-installer exits with stracktrace on F19

Added by Lukas Zapletal about 9 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
High
Assignee:
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

[root@lzap-aa ~]# foreman-installer 
/usr/share/gems/gems/kafo-0.0.14/lib/kafo/kafo_configure.rb:198:in `rescue in block in run_installation': undefined method `exitstatus' for nil:NilClass (NoMethodError)
        from /usr/share/gems/gems/kafo-0.0.14/lib/kafo/kafo_configure.rb:194:in `block in run_installation'
        from /usr/share/gems/gems/kafo-0.0.14/lib/kafo/kafo_configure.rb:193:in `spawn'
        from /usr/share/gems/gems/kafo-0.0.14/lib/kafo/kafo_configure.rb:193:in `run_installation'
        from /usr/share/gems/gems/kafo-0.0.14/lib/kafo/kafo_configure.rb:70:in `block in execute'
        from /usr/share/gems/gems/kafo-0.0.14/lib/kafo/kafo_configure.rb:42:in `catch'
        from /usr/share/gems/gems/kafo-0.0.14/lib/kafo/kafo_configure.rb:42:in `execute'
        from /usr/share/gems/gems/clamp-0.6.1/lib/clamp/command.rb:67:in `run'
        from /usr/share/gems/gems/clamp-0.6.1/lib/clamp/command.rb:125:in `run'
        from /usr/share/gems/gems/kafo-0.0.14/lib/kafo/kafo_configure.rb:77:in `block in run'
        from /usr/share/gems/gems/kafo-0.0.14/lib/kafo/kafo_configure.rb:76:in `catch'
        from /usr/share/gems/gems/kafo-0.0.14/lib/kafo/kafo_configure.rb:76:in `run'
        from /usr/sbin/foreman-installer:6:in `<main>'


Related issues

Is duplicate of Kafo - Bug #3175: Error: undefined method `exitstatus' when puppet run was not ok (0.1.0)Closed2013-10-01

Associated revisions

Revision c78f5830 (diff)
Added by Marek Hulán about 9 years ago

Fixes #3084 - PTY.check should never return nil

Revision 91e4fdc6
Added by Marek Hulán about 9 years ago

Merge pull request #14 from ares/bug/3084_exit_status

Fixes #3084 - PTY.check should never return nil

History

#1 Updated by Marek Hulán about 9 years ago

  • Status changed from New to Ready For Testing
  • Assignee set to Marek Hulán

Lukas could you please test the fix? Here's scratch build for F19 of kafo that should fix it. Note that is's not released as a new version yet.

#3 Updated by Marek Hulán about 9 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#4 Updated by Lukas Zapletal about 9 years ago

  • Is duplicate of Bug #3175: Error: undefined method `exitstatus' when puppet run was not ok (0.1.0) added

#5 Updated by Lukas Zapletal about 9 years ago

For some reason, this fix is not in the kafo 0.1.0 package that is in nightly and 1.3:

[lzap@lzapx ~]$ kojikat list-tagged --quiet --latest foreman-nightly-fedora18 | awk '{print $1}' | grep kafo
rubygem-kafo-0.1.0-1.fc18
[lzap@lzapx ~]$ kojikat list-tagged --quiet --latest foreman-1.3-fedora18 | awk '{print $1}' | grep kafo
rubygem-kafo-0.1.0-1.fc18

#6 Updated by Lukas Zapletal about 9 years ago

Oh it is there, but apparently it was not fixed:

http://koji.katello.org/koji/buildinfo?buildID=6532

* Fri Sep 13 2013 Marek Hulan <mhulan@redhat.com> 0.0.14-1
- Fixes #3078 - system checks fix for Ruby 1.8.7 (mhulan@redhat.com)

#7 Updated by Marek Hulán about 9 years ago

  • Status changed from Closed to Assigned
  • % Done changed from 100 to 0

reopening to investigate and fix

#8 Updated by Marek Hulán about 9 years ago

  • Status changed from Assigned to Closed
  • % Done changed from 0 to 100

ah sorry, I missed that you create a dup for that, closing again

Also available in: Atom PDF