Project

General

Profile

Feature #30867

Pulp3 - Docker tag upload from hammer

Added by Samir Jha almost 2 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Container
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

With pulp2 we were using the /actions/import_upload/ endpoint with params for tag name and digest for a manifest to tag a manifest. This is used in hammer today with pulp2 to upload tags.

I am not aware of a similar flow with pulp3 and could we add it if not currently implemented. The flow with pulp2 upload tag is we created an uplaod request and then call import upload with a tag name and a digest value for the manifest we need to tag.

Let me know if additional context is needed around this. For reference, In pulp2, the exact call from our binding that does this is here: https://github.com/Katello/runcible/blob/4a3b3118f77dc6a70d2ca499cbce483e3af32131/lib/runcible/resources/content.rb#L42

We need this endpoint implemented in pulp3. The issue is tracked here: https://pulp.plan.io/issues/7520

Once we have that, we need to make necessary changes to support this feature with pulp3.

Associated revisions

Revision 359a8dd1 (diff)
Added by Samir Jha over 1 year ago

Fixes #30867 - Tag a manifest from hammer (pulp3) (#9054)

History

#1 Updated by Ian Ballou almost 2 years ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.18.0

#2 Updated by The Foreman Bot over 1 year ago

  • Assignee set to Samir Jha
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/9054 added

#3 Updated by The Foreman Bot over 1 year ago

  • Fixed in Releases Katello 4.0.0 added

#4 Updated by Samir Jha over 1 year ago

  • Status changed from Ready For Testing to Closed

#5 Updated by Ian Ballou 9 months ago

  • Related to Bug #33767: Update or remove support for uploading container manifests added

#6 Updated by Ian Ballou 9 months ago

  • Related to deleted (Bug #33767: Update or remove support for uploading container manifests)

Also available in: Atom PDF