Project

General

Profile

Feature #30888

Proxy-Upgrade playbook - Error message for target version is not user friendly

Added by Ondřej Ezr about 1 month ago. Updated about 1 month ago.

Status:
New
Priority:
Normal
Assignee:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1870928

Description of problem:

[RFE] Appropriate error should be displayed if incorrect target version is provided while running capsule upgrade playbook job

Version-Release number of selected component (if applicable):
Red Hat Satellite 6.8 Beta

How reproducible: Always

Steps to Reproduce:
1. Navigate to the following path in Satellite GUI: Monitor >> Jobs >> Click on "Run Job"
2. Fill in the following details and click on "Submit":

---
Job category - Ansible Playbook
Job template - Capsule Upgrade Playbook
Search Query - name = (Your_Capsule_FQDN)

Actual results:
The job will fail as the "target_version" specified is incorrect but doesn't clearly states that the target versoin was the issue.

Expected results:
The failed job should state the "target_version" issue clearly.\n\n*Additional info:*'

History

#1 Updated by Ondřej Ezr about 1 month ago

  • Description updated (diff)
  • Subject changed from b'Appropriate error should be displayed if incorrect target version is provided while running capsule upgrade playbook job' to Proxy-Upgrade playbook - Error message for target version is not user friendly

Also available in: Atom PDF