Project

General

Profile

Bug #30914

hammer ping reports pulp on Pulp3-only installs

Added by Evgeni Golov over 1 year ago. Updated over 1 year ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Hammer
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

katello.yml:

:katello:
  :rest_client_timeout: 3600

  :content_types:
    :file: true
    :yum: true
    :deb: true
    :puppet: true
    :docker: true
    :ostree: false

  :candlepin:
    :url: https://localhost:23443/candlepin
    :oauth_key: "katello" 
    :oauth_secret: "sxz4mnQNLHsob62XoVocNv9x7BEhWXho" 
    :ca_cert_file: /etc/pki/katello/certs/katello-default-ca.crt

  :candlepin_events:
    :ssl_cert_file: /etc/pki/katello/certs/java-client.crt
    :ssl_key_file: /etc/pki/katello/private/java-client.key
    :ssl_ca_file: /etc/pki/katello/certs/katello-default-ca.crt

  :use_pulp_2_for_content_type:
    :docker: false
    :file: false
    :yum: false

  :katello_applicability: true

  # Internal configuration for communication from server to pulp crane service.
  :container_image_registry:
    :crane_url: https://centos8-katello-nightly.yatsu.example.com:5000
    :crane_ca_cert_file: /etc/pki/katello/certs/katello-server-ca.crt

And yet hammer ping lists pulp?

[root@centos8-katello-nightly ~]# hammer ping
database:         
    Status:          ok
    Server Response: Duration: 0ms
candlepin:        
    Status:          ok
    Server Response: Duration: 27ms
candlepin_events: 
    Status:          ok
    message:         0 Processed, 0 Failed
    Server Response: Duration: 0ms
candlepin_auth:   
    Status:          ok
    Server Response: Duration: 28ms
katello_events:   
    Status:          ok
    message:         0 Processed, 0 Failed
    Server Response: Duration: 0ms
pulp:             
    Status:          
    Server Response:
foreman_tasks:    
    Status:          ok
    Server Response: Duration: 3ms

Related issues

Is duplicate of Katello - Bug #31133: Hammer ping does not return Pulp 3 statusClosed

History

#1 Updated by Evgeni Golov over 1 year ago

  • Category set to Hammer

The API responds properly:

[root@centos8-katello-nightly ~]# curl -u admin:changeme -k https://localhost/api/v2/ping | /usr/libexec/platform-python -m json.tool
{
    "results": {
        "foreman": {
            "database": {
                "active": true,
                "duration_ms": "0" 
            }
        },
        "katello": {
            "services": {
                "candlepin": {
                    "status": "ok",
                    "duration_ms": "28" 
                },
                "candlepin_auth": {
                    "status": "ok",
                    "duration_ms": "35" 
                },
                "foreman_tasks": {
                    "status": "ok",
                    "duration_ms": "2" 
                },
                "katello_events": {
                    "status": "ok",
                    "message": "0 Processed, 0 Failed",
                    "duration_ms": "0" 
                },
                "candlepin_events": {
                    "status": "ok",
                    "message": "0 Processed, 0 Failed",
                    "duration_ms": "0" 
                },
                "pulp3": {
                    "status": "ok",
                    "duration_ms": "90" 
                }
            },
            "status": "ok" 
        }
    }
}

#2 Updated by John Mitsch over 1 year ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.18.0

#3 Updated by Ian Ballou over 1 year ago

  • Is duplicate of Bug #31133: Hammer ping does not return Pulp 3 status added

#4 Updated by Ian Ballou over 1 year ago

  • Status changed from New to Duplicate

#5 Updated by Ian Ballou over 1 year ago

  • Target version changed from Katello 3.18.0 to Katello Recycle Bin

Also available in: Atom PDF