Project

General

Profile

Bug #30919

sync_task fails with `The Dynflow world was not initialized yet.` in rake tasks on nightly production

Added by Samir Jha 8 months ago. Updated 8 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Orchestration
Target version:
-
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Cloning from the earlier issue where this was added to other rake tasks using Dynflow tasks. This issue is specifically for the katello:pulp3_post_migration_check as reported in community post :
https://community.theforeman.org/t/contentmigration-run-content-switchover-failed/20476

foreman-maintain advanced procedure run content-switchover
failed with :
Performing a check to verify everything that is needed has been migrated
[FAIL]
Failed executing foreman-rake katello:pulp3_post_migration_check, exit status 1:
rake aborted!
The Dynflow world was not initialized yet. If your plugin uses it, make sure to call Rails.application.dynflow.require! in some initializer

Related issues

Is duplicate of Katello - Bug #30937: katello:pulp3_post_migration_check fails with 'The Dynflow world was not initialized yet'Closed
Copied from Katello - Bug #29337: async_task fails with `The Dynflow world was not initialized yet.` in rake tasks on nightly productionClosed

History

#1 Updated by Samir Jha 8 months ago

  • Copied from Bug #29337: async_task fails with `The Dynflow world was not initialized yet.` in rake tasks on nightly production added

#2 Updated by Samir Jha 8 months ago

  • Triaged changed from Yes to No

#3 Updated by John Mitsch 8 months ago

  • Is duplicate of Bug #30937: katello:pulp3_post_migration_check fails with 'The Dynflow world was not initialized yet' added

#4 Updated by John Mitsch 8 months ago

  • Triaged changed from No to Yes
  • Status changed from New to Duplicate

Also available in: Atom PDF