Project

General

Profile

Feature #30956

Configure default repository set for subscriptions

Added by Gerald Vogt over 1 year ago. Updated over 1 year ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Subscriptions
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

For all custom products/subscriptions all repositories included are always enabled by default, i.e. if you add a product to a host it immediately enables all repositories for the product.

However, to reduce the number of products (which we don't use so often) we set up some "all-version" products, e.g. we have a PostgreSQL product which contains repositories for all current PostgreSQL versions from 9.4 to 13 as well as repositories for EL7 and EL8.

If I add postgresql to any host the host has all those repositories enabled.

It would be good, if it was possible to set this up in the subscription (similar to the way it gets this information from the manifest for RedHat subscriptions). I would set my postgresql product to have all repositories disabled by default and the user then needs to pick the version he needs.

The alternative at the moment seems to be to define a new product for each postgresql version and each os version and only define the necessary repositories for each product version, including the postgresql-common repository in each product...


Related issues

Is duplicate of Katello - Feature #24166: [sat-e-492] Allow adding releasever to custom reposClosed

History

#1 Updated by Jonathon Turel over 1 year ago

  • Is duplicate of Feature #24166: [sat-e-492] Allow adding releasever to custom repos added

#2 Updated by Jonathon Turel over 1 year ago

  • Triaged changed from No to Yes
  • Target version set to Katello Recycle Bin
  • Status changed from New to Duplicate

Hi Gerald,

Good news! We're currently working on the ability to set a 'release version' of sorts on custom products. I added the related issue to this one so you can track it. Closing this one out. Thanks for filing!

#3 Updated by Gerald Vogt over 1 year ago

Sorry to bother, but Feature #24166 is only partially doing what I was hoping for. It's good to have something which picks the correct repositories for a certain major os release version.

But that would still not help if you have multiple repositories for the same os release, e.g. various postgresql repositories from 9.4 to 13, all for el7. I would like to see all those disable by default and the user can pick a specific version repository and enable it.

Or the standard example of a CentOS 7 subscription which by default would have only os and updates repositories enabled and extras, plus, etc. disable by default.

For redhat subscriptions this information is included in the manifest. For custom products all repositories are enabled by default.

It's the default enabled column in the "hammer host subscription product-content" output.

#4 Updated by Gerald Vogt over 1 year ago

Sorry to bother again. But someone set this to duplicate and it's really not. I can't change this back. It's not about the release version it's about the 'default enable' setting for each repository inside a product (aka the column katello_product_contents.enabled in the database).

Also available in: Atom PDF