Project

General

Profile

Bug #30964

Katello Pulp 3 Applicability is incorrect when multiple versions of a package exist

Added by Jonathon Turel 4 months ago. Updated 17 days ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Hosts
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Filing based on https://community.theforeman.org/t/content-host-shows-installable-updates-package-updates-that-are-already-installed-and-running/20672/4 and my own reproduction.

To reproduce:

- vagrant up centos8
- register it to your dev env
- create a centos8 product with appstream and baseos repos (use 'background' policy) and sync
- attach centos8 subscription to the client
- for completeness remove all .repo under /etc/yum.repos.d/ except for redhat.repo
- subscription-manager refresh
- dnf upgrade kernel
on the client

Observe in the UI that the latest kernel has been installed but it still is reflected as an applicable package. I have a feeling this has to do with two packages with the same name being installed (ie two version of kernel) because upgrading `curl` correctly removes that package from the applicable list.

I see identical behavior currently in devel and 3.16


Related issues

Has duplicate Katello - Bug #31003: Katello Pulp 3 Applicability is incorrect when multiple versions of a package existDuplicate

Associated revisions

Revision 75daad0f (diff)
Added by Ian Ballou 17 days ago

Fixes #30964 - Applicability wrong with multiple rpm versions installed using Pulp 3 (#9078)

  • Fixes #30964 - Applicability wrong with multiple rpm versions installed
  • Refs #30964 - Merge duplicate query into main rpm query

History

#1 Updated by Jonathon Turel 4 months ago

  • Has duplicate Bug #31003: Katello Pulp 3 Applicability is incorrect when multiple versions of a package exist added

#2 Updated by Jonathon Turel 4 months ago

  • Subject changed from Applicable packages sometimes reported incorrectly to Katello Pulp 3 Applicability is incorrect when multiple versions of a package exist

#3 Updated by Jonathon Turel 4 months ago

  • Triaged changed from No to Yes

#4 Updated by Ian Ballou about 2 months ago

  • Target version changed from Katello 3.16.2 to 1341

#5 Updated by The Foreman Bot about 1 month ago

  • Assignee set to Ian Ballou
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/9078 added

#6 Updated by Ian Ballou about 1 month ago

  • Target version changed from 1341 to Katello 3.17.2

#7 Updated by The Foreman Bot 17 days ago

  • Fixed in Releases Katello 4.1.0 added

#8 Updated by Anonymous 17 days ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF