Project

General

Profile

Bug #31004

reporter_id needs to be set for hypervisor update

Added by Partha Aji almost 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Hosts
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Issue - reporter_id flag is not set for the hypervisor_update call while is set for the heartbeat

Typical Heartbeat on Satellite:
2020-10-06 10:43:03,056 [thread=http-bio-8443-exec-8] [req=413d456f-6a5a-4408-a504-1069c6bb7587, org=, csid=b18bebae-6978-481a-aeed-9098c9f9f95d] INFO org.candlepin.common.filter.LoggingFilter - Request: verb=PUT, uri=/candlepin/hypervisors/Default_Organization/heartbeat?reporter_id=ci-vm-10-0-139-143.hosted.upshift.rdu2.redhat.com-4dfa2c5125ab423ebed4b9cf8cdbe60d

While Hypervisor checkin on Satellite:
2020-10-06 10:43:03,319 [thread=http-bio-8443-exec-2] [req=489fcd9f-7291-462b-b893-d8271333af9a, org=, csid=1402b2bc-693c-42e7-b0b2-d6a2270096e2] INFO org.candlepin.common.filter.LoggingFilter - Request: verb=POST, uri=/candlepin/hypervisors/Default_Organization

Does not have the reporter_id param attached to it even though virt-who sends it. This causes the bug below. Katello needs to forward the reporter id similar to the way it does heart beat.

Original Bug
Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1860928

Description of problem:

Last checkin date/time not update when hypervisor is checked in via virt-who

Steps to Reproduce:
1. Configure virt-who
2. Last check-in for the Hypervisor is not "updated"

Actual results:

Last Checkin is "not" updated whenever virt-who is restarted in Red Hat Satellite v.6.7

Expected results:

Last check-in date should be updated.

Additional info:

Currently virt-who only sends the reports if changes detected compared to the previous shared reports to satellite. If no changes have happened in the reports, then the hypervisor will not change the check-in date/time for the hypervisor.

It appears to be a possible regression, where hypervisor Last checkin date/time not updated. As per BZ, [X] and [Y], this should have been fixed with Candlepin 2.9 and Satellite v.6.7, but the problem is still observed.

Associated revisions

Revision dd6bd935 (diff)
Added by Partha Aji almost 2 years ago

Fixes #31004 - Hypervisor update needs reporter_id (#8981)

Virt-Who when it calls katello for a hypervisor update, send the
reporter_id parameter. This needs to be forwarded to candlepin for it
to be correctly processed.

This commit forwards the reporter-id in addition to other parameters.

History

#1 Updated by Partha Aji almost 2 years ago

  • Bugzilla link set to 1860928

#2 Updated by The Foreman Bot almost 2 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/8981 added

#3 Updated by Jonathon Turel almost 2 years ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.18.0

#4 Updated by The Foreman Bot almost 2 years ago

  • Fixed in Releases Katello 4.0.0 added

#5 Updated by Partha Aji almost 2 years ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF