Project

General

Profile

Bug #31018

Pulpcore PostgreSQL database is not enforced to UTF-8

Added by Ewoud Kohl van Wijngaarden about 2 months ago. Updated about 1 month ago.

Status:
Closed
Priority:
Normal
Category:
Foreman modules
Target version:

Description

This often causes the database to be initialized as ASCII which then fails. https://community.theforeman.org/t/foreman-2-2-rc3-with-katello-3-16-on-centos-7-recommended-for-prod/20771/6 is just the latest example.

We should enforce it just like we do for Foreman's database.


Related issues

Has duplicate Installer - Bug #30697: Pulpcore database created with SQL_ASCII encodingDuplicate

Associated revisions

Revision 48b63dd7 (diff)
Added by Ewoud Kohl van Wijngaarden about 2 months ago

Fixes #31018 - Force UTF-8 database encoding

If this is not set, the environment is used. Often this causes the
database to be initialized as ASCII which breaks Pulpcore.

History

#1 Updated by The Foreman Bot about 2 months ago

  • Assignee set to Ewoud Kohl van Wijngaarden
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/puppet-pulpcore/pull/126 added

#2 Updated by Ewoud Kohl van Wijngaarden about 2 months ago

  • Status changed from Ready For Testing to Closed

#3 Updated by Ewoud Kohl van Wijngaarden about 2 months ago

  • Has duplicate Bug #30697: Pulpcore database created with SQL_ASCII encoding added

#4 Updated by The Foreman Bot about 2 months ago

  • Pull request https://github.com/theforeman/puppet-pulpcore/pull/130 added

#5 Updated by Tomer Brisker about 2 months ago

  • Target version changed from 2.1.4 to 2.2.0
  • Fixed in Releases 2.1.4 added

#6 Updated by The Foreman Bot about 2 months ago

  • Pull request https://github.com/theforeman/puppet-pulpcore/pull/133 added

#7 Updated by Tomer Brisker about 1 month ago

  • Fixed in Releases 2.2.0 added

Also available in: Atom PDF