Project

General

Profile

Bug #31201

EL8 clients do not always show available package updates and errata

Added by Eric Helms 12 months ago. Updated 7 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Using a repository pointed to https://jlsherrill.fedorapeople.org/fake-repos/needed-errata/ and an activation key containing the subscription for that Product/Repository.

When working with an EL8 client, the following workflow works to show available errata:

  • Register an EL8 client with sub-man using an activation key
  • yum install walrus-0.71
  • yum update show the correct results
  • hammer host errata list --host `hostname` shows the correct results

The workflow that does not appear to work:

  • Register with sub-man to --environment="Library"
  • Attach subscription through the UI
  • subscription-manager refresh
  • yum install walrus-0.71
  • yum update shows no update available
  • hammer host errata list --host `hostname` does not show available errata

History

#1 Updated by Ian Ballou 12 months ago

  • Triaged changed from No to Yes
  • Target version set to Katello 4.0.0

#2 Updated by James Jeffers 7 months ago

Attempted to reproduce on master:

[vagrant@centos8 ~]$ sudo yum install walrus-0.71
Updating Subscription Management repositories.
needs-errata                                                                                          51 kB/s | 6.3 kB     00:00    
Dependencies resolved.
=====================================================================================================================================
 Package             Architecture        Version                Repository                                                      Size
=====================================================================================================================================
Installing:
 walrus              noarch              0.71-1                 Default_Organization_errata-el8-test_needs-errata              2.4 k
Installing dependencies:
 shark               noarch              0.1-1                  Default_Organization_errata-el8-test_needs-errata              2.4 k
 stork               noarch              0.12-2                 Default_Organization_errata-el8-test_needs-errata              2.4 k
 whale               noarch              0.2-1                  Default_Organization_errata-el8-test_needs-errata              2.4 k

Transaction Summary
=====================================================================================================================================
Install  4 Packages

Total download size: 9.6 k
Installed size: 210  
Is this ok [y/N]: y
Downloading Packages:
(1/4): walrus-0.71-1.noarch.rpm                                                                       28 kB/s | 2.4 kB     00:00    
(2/4): whale-0.2-1.noarch.rpm                                                                         24 kB/s | 2.4 kB     00:00    
(3/4): shark-0.1-1.noarch.rpm                                                                         23 kB/s | 2.4 kB     00:00    
(4/4): stork-0.12-2.noarch.rpm                                                                       106 kB/s | 2.4 kB     00:00    
-------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                 84 kB/s | 9.6 kB     00:00     
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                                                                             1/1 
  Installing       : stork-0.12-2.noarch                                                                                         1/4 
  Installing       : shark-0.1-1.noarch                                                                                          2/4 
  Installing       : whale-0.2-1.noarch                                                                                          3/4 
  Installing       : walrus-0.71-1.noarch                                                                                        4/4 
  Verifying        : shark-0.1-1.noarch                                                                                          1/4 
  Verifying        : walrus-0.71-1.noarch                                                                                        2/4 
  Verifying        : whale-0.2-1.noarch                                                                                          3/4 
  Verifying        : stork-0.12-2.noarch                                                                                         4/4 
Installed products updated.

Installed:
  shark-0.1-1.noarch              stork-0.12-2.noarch              walrus-0.71-1.noarch              whale-0.2-1.noarch             

Complete!
[vagrant@centos8 ~]$ sudo yum update
Updating Subscription Management repositories.
needs-errata                                                                                          56 kB/s | 2.0 kB     00:00    
Dependencies resolved.
=====================================================================================================================================
 Package                 Arch   Version                                      Repository                                         Size
=====================================================================================================================================
Installing:
 kernel                  x86_64 4.18.0-240.15.1.el8_3                        baseos                                            4.3 M
...
 walrus                  noarch 5.21-1                                       Default_Organization_errata-el8-test_needs-errata 2.4 k
Installing dependencies:
 grub2-tools-efi         x86_64 1:2.02-90.el8_3.1                            baseos                                            471 k

Transaction Summary
=====================================================================================================================================
Install   4 Packages
Upgrade  38 Packages

Total download size: 216 M
Is this ok [y/N]: n

yum update indicates that there is an update to walrus.

#3 Updated by James Jeffers 7 months ago

  • Assignee set to James Jeffers

#4 Updated by James Jeffers 7 months ago

Also, hammer shows the errata (also shown in the UI):

[vagrant@centos7-hammer-devel hammer-cli-katello]$ hammer host errata list --host centos8.jjeffers.example.com
Warning: An error occured while loading module hammer_cli_foreman_remote_execution.
---|----------------|----------|-------------|------------
ID | ERRATUM ID     | TYPE     | TITLE       | INSTALLABLE
---|----------------|----------|-------------|------------
4  | RHEA-2012:0055 | security | Sea_Erratum | true       
---|----------------|----------|-------------|------------

#5 Updated by James Jeffers 7 months ago

  • Status changed from New to Closed

Closing this as unable to reproduce on 4.0 or master.

Also available in: Atom PDF