Project

General

Profile

Bug #31224

Cannot export content view in Katello 3.16

Added by Christoffer Reijer over 1 year ago. Updated over 1 year ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

I recently deployed Foreman 2.1 with Katello 3.16 and now my export / import Ansible tasks are failing.

# hammer content-view version export --id=4 --export-dir=/var/lib/pulp/katello-export/
Could not export the content view:
  Error: No such file or directory @ dir_chdir - /var/lib/pulp/published/yum/https/repos/

# ls -al /var/lib/pulp/published/
total 0
drwxrwxr-x. 3 apache apache  20 Oct 30 17:07 .
drwxrwxr-x. 8 pulp   pulp   157 Oct 30 18:08 ..
drwxrwxr-x. 3 apache apache  16 Oct 30 17:07 docker

I have published the content view and promoted it to environment "Production". I have a CentOS 8 machine with subscription-manager which is subscribed to Foreman and is able to download package alright.

The repository is set to "Immediate" and I can see all packages under /var/lib/pulp/docroot/artifact/.

I have tried exporting both a normal and a compose CV. Same result.


Related issues

Is duplicate of Katello - Bug #31117: Update hammer endpoint for export with pulp3Closed

History

#1 Updated by Ian Ballou over 1 year ago

  • Is duplicate of Bug #31117: Update hammer endpoint for export with pulp3 added

#2 Updated by Ian Ballou over 1 year ago

Hi Christoffer,

It's a known issue that content view export is not working in Katello 3.16. The issue occurs only if you're using Pulp 3 rather than Pulp 2. We are working on adding documentation to make this clear, so apologies for any confusion there.

#3 Updated by Ian Ballou over 1 year ago

  • Triaged changed from No to Yes
  • Target version set to Katello Recycle Bin
  • Status changed from New to Duplicate

Also available in: Atom PDF