Project

General

Profile

Bug #31245

Host registration UI fails with "wrong number of arguments (given 2, expected 1)"

Added by Peter Ondrejka 3 months ago. Updated 3 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Host registration
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

- In UI, navigate to Hosts > All Hosts, click Register Host
- select a hostgrou
- set one of "Remote Execution" or "Setup Insights"
- click "Generate command"

Observe: Oops, we're sorry but something went wrong wrong number of arguments (given 2, expected 1)
Error log attached

Other setting combinations work as expected

error-log error-log 14.8 KB Peter Ondrejka, 11/03/2020 02:49 PM

Related issues

Related to Foreman - Feature #30440: Simple & automatic host registration WFNew
Is duplicate of OpenSCAP - Bug #31186: Edit Host GUI broken with openscap_plugin installed on Foreman 2.2RC4, Katello 3.17RC2Closed

History

#1 Updated by Peter Ondrejka 3 months ago

  • Related to Feature #30440: Simple & automatic host registration WF added

#3 Updated by Marek Hulán 3 months ago

A quick workaround - don't set the host group

#4 Updated by Ondřej Pražák 3 months ago

  • Status changed from New to Duplicate

#5 Updated by Ondřej Pražák 3 months ago

  • Is duplicate of Bug #31186: Edit Host GUI broken with openscap_plugin installed on Foreman 2.2RC4, Katello 3.17RC2 added

#6 Updated by Ondřej Pražák 3 months ago

This should be fixed in foreman_openscap-4.0.4

Also available in: Atom PDF