Project

General

Profile

Bug #31338

[Foreman 2.3] [zh_CN/ja_JP] Localized string broken into two separate lines, at <Administer - Locations page>, at <Administer - Organizations page> and at <Infrastructure - Domains>.

Added by vijaykumar sawant about 1 year ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Internationalization
Target version:
-
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Description of problem: Localized string broken on multiple lines.

Version-Release number of selected component (if applicable): Version 2.3.0 RC1

How reproducible: Always

Steps to Reproduce:
1. Login to Foreman 2.3 instance with Japanese/Chinese language.
2. Navigate to Administer -> Locations page.
3. Click on any Location under Name column.
4. Switch to section link Parameters.

Actual results: Localized string split on two separate lines.

Expected results: Localized string should be on same line.

Additional info: Same issue can be seen at different place as well
Steps to reproduce
[1] Navigate to Administer - Organizations page, click on any Organization under Name column and switch to Parameters section.
[2] Navigate to Infrastructure - Domains page, click on any Domain under Description column and switch to tab Parameters.
Please see attached screenshot.

TS2_Edit_location_option_parameters.png View TS2_Edit_location_option_parameters.png 134 KB Administer -> Locations page vijaykumar sawant, 11/19/2020 06:50 AM
TS2_edit-organization-paramters-section.png View TS2_edit-organization-paramters-section.png 139 KB Administer - Organizations page vijaykumar sawant, 11/19/2020 06:51 AM
TS2_Create-Domain-Parameter-tab-localized-string-broken-into-multiple-lines.png View TS2_Create-Domain-Parameter-tab-localized-string-broken-into-multiple-lines.png 111 KB Infrastructure - Domains page vijaykumar sawant, 11/19/2020 06:51 AM
Ts2 edit location option parameters Ts2 edit organization paramters section Ts2 create domain parameter tab localized string broken into multiple lines

History

#1 Updated by vijaykumar sawant 8 months ago

  • Triaged changed from No to Yes
  • Found in Releases 2.5.0 added
  • Found in Releases deleted (2.3.0)

vijaykumar sawant wrote:

This issue has been observed in Foreman 2.5 RC2

#2 Updated by vijaykumar sawant about 2 months ago

  • Status changed from New to Resolved
  • Fixed in Releases 3.1.0 added

Verified on Foreman 3.1 RC-2 build using zh_CN and ja_JP locale
The issue is not found, hence closing this bug.

Also available in: Atom PDF