Project

General

Profile

Bug #3142

rubygem(ancestry) < 1.4.0 conflicts with f19-updates

Added by Alan Pevec over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Urgent
Category:
Packaging
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

When updating F19 with Foreman 1.2 repo enabled I get:

Error: Package: foreman-1.2.2-1.fc19.noarch (@foreman)
Requires: rubygem(ancestry) < 1.4.0
Removing: rubygem-ancestry-1.3.0-4.fc19.noarch (@foreman)
rubygem(ancestry) = 1.3.0
Updated By: rubygem-ancestry-2.0.0-5.fc19.noarch (updates)
rubygem(ancestry) = 2.0.0

Associated revisions

Revision 18722e76 (diff)
Added by Lukas Zapletal over 5 years ago

fixes #3142 - update ancestry due to dependency issue in f19

Revision 3e1e8e93 (diff)
Added by Lukas Zapletal over 5 years ago

fixes #3142 - update ancestry due to dependency issue in f19

(cherry picked from commit 18722e769927f406d813fec1aed1b2d7c7f3b6a1)

Conflicts:
foreman.spec

Revision df3706d0 (diff)
Added by Lukas Zapletal over 5 years ago

fixes #3142 - update ancestry due to dependency issue in f19

(cherry picked from commit 18722e769927f406d813fec1aed1b2d7c7f3b6a1)

History

#1 Updated by Dominic Cleal over 5 years ago

  • Category set to Packaging
  • Priority changed from Normal to Urgent
  • Target version set to 1.3.0

I think we can just bump the version requirements to permit 2.x in the Gemfile and spec file. I haven't tested the new release, but the CHANGELOG reports they dropped Rails 2 so it shouldn't affect us.

#2 Updated by Lukas Zapletal over 5 years ago

I missed the fact this is new package in Fedora 19. Not an update. We need to bump.

#3 Updated by Lukas Zapletal over 5 years ago

  • Related to Tracker #3112: [TRACKER] Issues to be released in 1.3 RC or final added

#5 Updated by Lukas Zapletal over 5 years ago

Please ignore f19 build - it is irrelevant.

https://bugzilla.redhat.com/show_bug.cgi?id=996618

#7 Updated by Lukas Zapletal over 5 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#8 Updated by Dominic Cleal over 5 years ago

  • Target version changed from 1.3.0 to 1.2.3

#9 Updated by Lukas Zapletal over 5 years ago

  • Related to deleted (Tracker #3112: [TRACKER] Issues to be released in 1.3 RC or final)

Also available in: Atom PDF