Project

General

Profile

Bug #3143

Installer for 1.3 overwrites custom repo

Added by Lukas Zapletal about 7 years ago. Updated over 2 years ago.

Status:
Rejected
Priority:
High
Category:
foreman-installer script
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

By default we now deploy custom_repo: true for both foreman and proxy in Foreman 1.3 RC2.

For some reason, this gets overwritten, so RC fails.

History

#1 Updated by Lukas Zapletal about 7 years ago

  • Related to Tracker #3112: [TRACKER] Issues to be released in 1.3 RC or final added

#2 Updated by Greg Sutcliffe about 7 years ago

I couldn't reproduce this on any Debian OS yesterday - a clean install, add the foreman 1.3 repo, and execute "foreman-installer -v" seems to work fine. I'll retest to be sure, once I have repaired my OpenStack box...

#3 Updated by Greg Sutcliffe about 7 years ago

I can't replicate this on wheezy at all:

root@installer1:~# cat /usr/share/foreman-installer/config/answers.yaml |grep custom_repo
custom_repo: true
custom_repo: true
root@installer1:~# ls /etc/apt/sources.list.d/
puppetlabs.list

Maybe something odd in the RPM packages?

#4 Updated by Lukas Zapletal about 7 years ago

  • Status changed from New to Assigned
  • Assignee set to Lukas Zapletal

Sorry guys, I need to check this one on my own. For some reason it was happenning to me, not sure if I was doing something wrong. Lemme check that by EOW.

#5 Updated by Lukas Zapletal about 7 years ago

  • Related to deleted (Tracker #3112: [TRACKER] Issues to be released in 1.3 RC or final)

#6 Updated by Lukas Zapletal about 7 years ago

  • Status changed from Assigned to Rejected

Not able to reproduce with yum.tf.org repos.

Also available in: Atom PDF